If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TM: Immediate Crash loading news.com with content jit on

VERIFIED FIXED

Status

()

Core
JavaScript Engine
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Mike Schroepfer, Assigned: brendan)

Tracking

Trunk
All
Mac OS X
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
STR:

1) Launch firefox with content.jit set to true
2) Type www.news.com into url bar and hit enter
3) Crash:

37ec462e-706b-11dd-93bd-001cc45a2c28	8/22/08	9:56 AM
27eb53de-706b-11dd-a66e-001a4bd43ed6	8/22/08	9:55 AM
1b22b214-706b-11dd-90ff-0013211cbf8a	8/22/08	9:55 AM
0f619894-706b-11dd-82ea-001cc45a2ce4	8/22/08	9:55 AM
(Reporter)

Comment 1

9 years ago
This is with the 8-22 mozcentral nightly:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080822021301 Minefield/3.1a2pre

Updated

9 years ago
Blocks: 451602

Comment 2

9 years ago
also bug 451743 ?
Pushed fix for tracemonkey branch in changeset e8bbd0465e6c.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 451983
Nice try but both www.news.com and news.cnet.com both still crash with:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080826034105 Minefield/3.1a2pre

Doesn't this need to be pushed to mozilla-central in order to be resolved as fixed?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

9 years ago
Sorry, I should have propagated this change to m-c. Will do so when tree opens in an hour.

/be
Assignee: general → brendan
Status: REOPENED → NEW
(Assignee)

Comment 7

9 years ago
Fixed on mozilla-central:

http://hg.mozilla.org/mozilla-central/index.cgi/rev/074d733dbdb8

/be
Status: NEW → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20080927020752 Minefield/3.1b1pre ID:20080927020752
Status: RESOLVED → VERIFIED
Hardware: Macintosh → All

Updated

9 years ago
Flags: in-testsuite-
Flags: in-litmus-
You need to log in before you can comment on or make changes to this bug.