<type 'exceptions.NameError'>: global name 'WARNINGS' is not defined

RESOLVED DUPLICATE of bug 451734

Status

Release Engineering
General
--
major
RESOLVED DUPLICATE of bug 451734
9 years ago
4 years ago

People

(Reporter: myk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Since TraceMonkey landed yesterday afternoon, buildbot has been failing on Linux and Mac leak test boxes with the following traceback (most recent call last):
  File "/tools/twisted-2.4.0/lib/python2.5/site-packages/twisted/internet/defer.py", line 182, in addCallbacks
    self._runCallbacks()
  File "/tools/twisted-2.4.0/lib/python2.5/site-packages/twisted/internet/defer.py", line 307, in _runCallbacks
    self.result = callback(self.result, *args, **kw)
  File "/tools/twisted-2.4.0/lib/python2.5/site-packages/twisted/internet/defer.py", line 229, in callback
    self._startRunCallbacks(result)
  File "/tools/twisted-2.4.0/lib/python2.5/site-packages/twisted/internet/defer.py", line 294, in _startRunCallbacks
    self._runCallbacks()
--- <exception caught here> ---
  File "/tools/twisted-2.4.0/lib/python2.5/site-packages/twisted/internet/defer.py", line 307, in _runCallbacks
    self.result = callback(self.result, *args, **kw)
  File "/tools/buildbot-077/lib/python2.5/site-packages/buildbot/process/buildstep.py", line 967, in <lambda>
    d.addCallback(lambda res: self.evaluateCommand(cmd)) # returns results
  File "/tools/buildbotcustom/buildbotcustom/steps/test.py", line 211, in evaluateCommand
    summary += line
<type 'exceptions.NameError'>: global name 'WARNINGS' is not defined

Here are sample logs:

Linux: http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1219418901.1219420509.27459.gz

Mac: http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1219418901.1219419190.23502.gz
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 451734
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.