Sorting columns in buglists is not remembered between calls to buglist.cgi

RESOLVED DUPLICATE of bug 425619

Status

()

bugzilla.mozilla.org
General
--
major
RESOLVED DUPLICATE of bug 425619
9 years ago
6 years ago

People

(Reporter: Frédéric Buclin, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
query.cgi offers a very limited set of sortkeys (bug ID, importance, assignee and last changed). When you click on column headers to change the sort order of buglists, this order is only remembered for the current buglist. If you go else where and then do another query, the old sort order comes back again. The only workaround I found is to hack the URL to pass order=, but that's the job of the JS sort order script to update the cookie for me.

I thought this was a dupe, but maybe not.
(Reporter)

Updated

9 years ago
Blocks: 450310

Comment 1

9 years ago
It is a dupe, and it may be marked fixed already, as the code that fixes it is in my repo.
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> It is a dupe, and it may be marked fixed already, as the code that fixes it is
> in my repo.

justdave just updated bugzilla-stage right now, and merged all changes, and I can still reproduce this irritating bug. Every time I do a query, it's sorted by bug status again.

Comment 3

9 years ago
Can you reproduce it on the current bmo?
(Reporter)

Comment 4

9 years ago
Yes. I forced order=bugs.bug_id once several months ago (by appending it to the URL) so that all buglists fall back to it instead of the irritating bug status. But there is no way to override this when clicking on column headers.

Comment 5

9 years ago
Okay, so it's not a regression, and it's a dup of bug 425619.
No longer blocks: 450310
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425619
(Assignee)

Updated

6 years ago
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.