If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Message | Mark | All Read crashes win32

VERIFIED DUPLICATE of bug 45184

Status

MailNews Core
Backend
P3
major
VERIFIED DUPLICATE of bug 45184
17 years ago
9 years ago

People

(Reporter: Jon Granrose, Assigned: Scott MacGregor)

Tracking

({crash, topcrash})

Trunk
x86
Windows NT
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
On my Dell laptop running NT 4.0 sp4 in today's build (2000071108) if I am
reading news and then do a "Message | Mark | All Read" on any newsgroup, it crashes.

URL to talkback report is above.  I'll attach the stack trace separately.
(Reporter)

Comment 1

17 years ago
Cutting and pasting was giving me trouble, so here's the stack trace:

    rdf_HashWideString
[d:\builds\seamonkey\mozilla\rdf\base\src\nsRDFService.cpp, line 451]
LiteralImpl::~LiteralImpl
[d:\builds\seamonkey\mozilla\rdf\base\src\nsRDFService.cpp, line 177]
LiteralImpl::`scalar deleting destructor'       LiteralImpl::Release
[d:\builds\seamonkey\mozilla\rdf\base\src\nsRDFService.cpp, line 185]
nsCOMPtr_base::~nsCOMPtr_base
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 50]
nsMsgFolderDataSource::OnItemPropertyFlagChanged
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgFolderDataSource.cpp, line
831]     LiteralImpl::~LiteralImpl
[d:\builds\seamonkey\mozilla\rdf\base\src\nsRDFService.cpp, line 177]
LiteralImpl::`scalar deleting destructor'       LiteralImpl::Release
[d:\builds\seamonkey\mozilla\rdf\base\src\nsRDFService.cpp, line 185]
nsCOMPtr_base::~nsCOMPtr_base
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 50]
nsMsgFolderDataSource::OnItemPropertyFlagChanged
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgFolderDataSource.cpp, line
831]     nsMsgMessageDataSource::OnChangeStatus
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgMessageDataSource.cpp, line
939]     nsMsgMessageDataSource::OnItemPropertyFlagChanged
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgMessageDataSource.cpp, line
912]     nsMsgMailSession::OnItemPropertyFlagChanged
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgMailSession.cpp, line 193]
   nsMsgFolder::NotifyPropertyFlagChanged
[d:\builds\seamonkey\mozilla\mailnews\base\util\nsMsgFolder.cpp, line 2241]
nsMsgDBFolder::SendFlagNotifications
[d:\builds\seamonkey\mozilla\mailnews\base\util\nsMsgDBFolder.cpp, line 485]
 nsMsgDBFolder::OnKeyChange
[d:\builds\seamonkey\mozilla\mailnews\base\util\nsMsgDBFolder.cpp, line 630]
 nsMsgDatabase::NotifyKeyChangeAll
[d:\builds\seamonkey\mozilla\mailnews\db\msgdb\src\nsMsgDatabase.cpp, line 280]
    nsMsgDatabase::MarkHdrReadInDB
[d:\builds\seamonkey\mozilla\mailnews\db\msgdb\src\nsMsgDatabase.cpp, line 1377]
    nsMsgDatabase::MarkHdrRead
[d:\builds\seamonkey\mozilla\mailnews\db\msgdb\src\nsMsgDatabase.cpp, line 1648]
    nsMsgDatabase::MarkAllRead
[d:\builds\seamonkey\mozilla\mailnews\db\msgdb\src\nsMsgDatabase.cpp, line 1694]
    nsMsgDBFolder::MarkAllMessagesRead
[d:\builds\seamonkey\mozilla\mailnews\base\util\nsMsgDBFolder.cpp, line 957]
 nsMsgFolderDataSource::DoCommand
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgFolderDataSource.cpp, line
649]     CompositeDataSourceImpl::DoCommand
[d:\builds\seamonkey\mozilla\rdf\base\src\nsCompositeDataSource.cpp, line 1292]
    XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 139]     nsXPCWrappedNativeClass::CallWrappedMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativeclass.cpp,
line 915]     WrappedNative_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 195]     js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line
717]     js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2521]
    js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 733]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 806]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2817]
 nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 850]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 155]
 nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
773]     nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
1653]     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3350]
PresShell::HandleDOMEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3956]
  nsMenuFrame::Execute
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 1429]
 nsMenuFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 323]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3925]
  PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3843]
  nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line
782]     nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp,
line 755]     nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 755]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 755]
    nsViewManager2::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1389]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 564]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 581]
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3689]
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3894]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2809]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 830]
USER32.dll + 0x1268 (0x77e71268)
Keywords: crash
(Assignee)

Comment 2

17 years ago
putterman/waterson does this belong to one of you? Looks like we are crashing
trying to delete an rdf literal.

Updated

17 years ago
QA Contact: lchiang → fenella
(Assignee)

Comment 3

17 years ago
bienvenu thinks this is a dup of a bug alecf owns.

Comment 4

17 years ago
same stack as 45184

*** This bug has been marked as a duplicate of 45184 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
Mark as verified/dup.
Status: RESOLVED → VERIFIED

Comment 6

17 years ago
Adding topcrash, this made the top5 talkback crash list today.
Keywords: topcrash
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.