Lost forum filter parameters on pagination

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: jason.barnabe, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tiki_fixed (use of Tiki4 as-is should be fine), URL)

(Reporter)

Description

10 years ago
Go to: http://support.mozilla.com/tiki-view_forum.php?forumId=1&comments_threshold=0&thread_sort_mode=lastPost_desc&comments_per_page=20&time_control=&poster=np&issue_solved=&reply_state=&comments_offset=0

This is a list of threads I've posted in (URL contains poster=np)

Click on Page 2. You've now lost the filter (URL contains poster=)

This used to work.

Comment 1

10 years ago
I don't even get any search results here. What's up with that?

Comment 2

9 years ago
Looks like we fixed this. 

https://support.mozilla.com/tiki-searchindex.php?words=a&where=forums&advancedfsearch=y&forumId=1&author=djstsys&daysBefore=

(If you leave the Keywords field blank, you won't get any results, and not even a message saying "0 results found" or "Your search is too generic."; that's a separate bug though, and I don't think it's worth filing it, as I assume few people use the advanced search on the forum anyway)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Whiteboard: tiki_triage

Comment 3

9 years ago
pagination has been rewritten & centralized since Tiki 1.10

Should be tested with real data on Tiki4, but should be OK.
Whiteboard: tiki_triage → tiki_fixed (use of Tiki4 as-is should be fine)
You need to log in before you can comment on or make changes to this bug.