alt enter on location bar steels focus although preference is otherwise

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: eyaler, Unassigned)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking-firefox3.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

alt enter on location bar or middle click on go arrow, opens in a new tab, and switches to it. this is so although the option:
"when i open a link in a new tab, switch to it immediately" 
is unchecked.
thus i get a focus switch although a specifically unchecked this option

Reproducible: Always

Steps to Reproduce:
1. uncheck "when i open a link in a new tab, switch to it immediately" 
2. type a url in location bar and alt+enter or middle click on go arrow
Actual Results:  
url is opened in new tab and the focus is switched to the new tab

Expected Results:  
url should be opned in a new tab without focus switch
In about:config go to the pref browser.tabs.loadBookmarksInBackground and set it to true.
http://kb.mozillazine.org/About:config
(Reporter)

Comment 2

10 years ago
setting browser.tabs.loadBookmarksInBackground=true fixes the behavior for middle-click on go arrow

however alt-enter still steals the focus and does it in the foreground

moreover why should the preference for bookmarks be relevant also for url's typed in the location bar?
I believe to remember that Gavin Sharp made the middle click on the Go-button possible.
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> I believe to remember that Gavin Sharp made the middle click on the Go-button
> possible.

it is.
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3.1?
Alt-Enter opens in a new tab, with focus, by design. The preference described as "when I open a link in a new tab, switch to it immediately" is about opening links in web pages by clicking, not about typing things into the URL bar.

When typing something into the URL bar, we assume that the user wants to act on the content at the destination URL. I believe this is a correct assumption, and am not interested in supporting the alternative use case. Sorry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-firefox3.1? → blocking-firefox3.1-
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.