Note: There are a few cases of duplicates in user autocompletion which are being worked on.

hg.mozilla.org should serve well-formed xhtmls

RESOLVED FIXED

Status

Developer Services
Mercurial: hg.mozilla.org
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: Takeshi Kurosawa, Assigned: Takeshi Kurosawa)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Created attachment 335145 [details] [diff] [review]
Patch

hg.mozilla.org serves not well-formed XHTMLs despite their declaration (XHTML 1.0 Strict). 
For example,
- unclosed <img> or <br>
- <script> which contains unescaped "<"

We should fix them.
Attachment #335145 - Flags: review?(ted.mielczarek)
Attachment #335145 - Flags: review?(ted.mielczarek) → review+
Duplicate of this bug: 453974
What else is needed, in order to bring this into effect?
Ted, since you reviewed this, can you also please check this in? Thanks.
Keywords: checkin-needed
Assignee: nobody → taken.spc
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: PC → All
Pushed:
http://hg.mozilla.org/hg_templates/rev/6ecba8c90c67

(this will go live next time we need a site update)
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering

Comment 5

3 years ago
https://hg.mozilla.org/hgcustom/version-control-tools/rev/d209b948ed54
Product: Release Engineering → Developer Services
You need to log in before you can comment on or make changes to this bug.