progress bar for file uploads

VERIFIED DUPLICATE of bug 249338

Status

()

Firefox
General
--
enhancement
VERIFIED DUPLICATE of bug 249338
10 years ago
10 years ago

People

(Reporter: Olé, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

this is not a real bug but a missed feature

when sending huge files info a form there should be a progress bar after clicking the submit button. just to show the user how long he must wait and convince him, that the browser is not just frozen

this is basic feature that flash-uploads provides and with html this is impossible and that should not be a thing that the web developers should integrate but it should be inside of the browser. maybe in the same style like the Ctrl+tab function in ff 3.1

what do you think

Reproducible: Always

Steps to Reproduce:
1. choose a huge file for a standard fire upload
2. press submit


Actual Results:  
the browser begins to send the file and no one knows how long this will take. maybe the connection is too slow and the upload will take half an hour, but you can not be sure

Expected Results:  
a progress bar should appear that shows how long the upload will take

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 249338

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.