Closed Bug 451854 Opened 14 years ago Closed 14 years ago

Use new search textbox widget for search in address book

Categories

(Thunderbird :: Address Book, defect)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 454010

People

(Reporter: whimboo, Unassigned)

References

Details

Attachments

(1 file)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080823025946 Shredder/3.0b1pre

The search field inside the address book only supports searching for "Name or Email". That way the picker is useless. Replacing this box with the new search textbox widget will increase the user experience. See the attached image.
I'm (at least initially) against replacing this search field in this manner - i.e. loosing the extra picker for changing the option to search.

Although we don't currently offer more than one search possibility, we have various bugs on file that indicate they would like us to extend the picker.

I'd certainly like to know what Bryan thinks of that before doing this.

Note: the complete search widget is currently an xbl binding - the timed-textbox is part of that xbl, so we'd be looking at replacing the timed-textbox in the binding with the search field, so we'd still keep the same functionality. This would actually fix it for the Address Book toolbar, Contacts Sidebar and Main Mail Window all in one go.
(In reply to comment #1)
> Note: the complete search widget is currently an xbl binding - the
> timed-textbox is part of that xbl, so we'd be looking at replacing the
> timed-textbox in the binding with the search field, so we'd still keep the same
> functionality. This would actually fix it for the Address Book toolbar,
> Contacts Sidebar and Main Mail Window all in one go.

Dao, would there be a way to enhance the search textbox widget by giving the availability to add several customized search criteria, e.g. for Thunderbird: Sender, To or CC, Subject? All these could be made visible by using the little drop down picker.
Blocks: 454010
We now have three bugs to do one thing. Therefore duping to bug 454010 as that contains most information.
No longer blocks: 454010
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 454010
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.