Closed Bug 451864 Opened 13 years ago Closed 13 years ago

Assertion failure: sprop->getter == js_GetCallVar, at c:/gecko2_0/src/js/src/jstracer.cpp:2356

Categories

(Core :: JavaScript Engine, defect)

x86
Windows Vista
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 451806

People

(Reporter: WeirdAl, Unassigned)

References

Details

(Keywords: assertion, crash)

Attachments

(1 file)

Attached file stack trace
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/20080822225109 Minefield/3.1a2pre

Steps to reproduce:

(0) In preferences, javascript.options.jit.chrome = true, javascript.options.jit.content = true
(1) Visit slashdot.org
(2) Open in new tab http://arstechnica.com/news.ars/post/20080822-firefox-to-get-massive-javascript-performance-boost.html (linked from Slashdot).
(3) Wait approximately 15 seconds.

Failed on:
JS_ASSERT(sprop->getter == js_GetCallVar);

Looks to be having a problem with executing "_brand2_doFillProducts();" from 

+		filename	0x06df0038 "http://www.tumri.net/ads/ads?client=lenovo&ad_type=skyscraper&tumri_theme=Lenovo-Google&tumri_click_tracker_url=http%3A%2F%2Fad.doubleclick.net%2Fclick%253Bh%3Dv8%2F3725%2Ff%2F142%2F%252a%2Fr%253B206607464%253B0-0%253B0%253B28969838%253B2321-160%2F600%253B27728145%2F27746024%2F1%253B%253B%257Esscs%253D%253fhttp%3A%2F%2Fpagead2.googlesyndication.com%2Fpagead%2Ficlk%3Fsa%3Dl%26ai%3DBiqU	const char *
		lineno	1394	unsigned int
Keywords: crash
Assignee: nobody → general
Component: Tracing Virtual Machine → JavaScript Engine
Product: Tamarin → Core
QA Contact: tracing-vm → general
Version: unspecified → Trunk
100% reproducible, just by loading the above tumri.net URI.
Blocks: 451602
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 451806
You need to log in before you can comment on or make changes to this bug.