TM: Crash [@ js_EqualStrings] loading Engadget

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Michael Clackler, Unassigned)

Tracking

({crash})

Trunk
mozilla1.9.1
x86
Windows Vista
crash
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/20080823032129 Minefield/3.1a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/20080823032129 Minefield/3.1a2pre

With javascript.options.jit.content enabled (true) firefox crashes immediately when opening Engadget.  Verified crash remains in safe mode.  Crash exists in 20080822 and 20080823 build.  Does not crash with JIT disabled.

Reproducible: Always

Steps to Reproduce:
1. Enable javascript.options.jit.content in about:confg
2. open http://engadget.com
Actual Results:  
Browser crashes

Expected Results:  
Engadget page is displayed

Two crash reports:
20080822 build:
http://crash-stats.mozilla.com/report/index/562cbf61-70ac-11dd-8f41-001321b13766

20080823 build (in safemode):
http://crash-stats.mozilla.com/report/index/c5efceb5-7149-11dd-9cca-001a4bd43e5c?p=1
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: General → JavaScript Engine
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → general
Target Milestone: --- → mozilla1.9.1
Version: unspecified → Trunk
Michael, thanks for filing.

TM folks, please take this bug if you have time over the weekend. Thanks,

/be

Comment 2

9 years ago
I think David was looking into this on Friday. Adding him.

Updated

9 years ago
Keywords: crash
Summary: TM: Crash @ js_EqualStrings loading Engadget → TM: Crash [@ js_EqualStrings] loading Engadget
Flags: blocking1.9.1?

Comment 3

9 years ago
Same problem with www.autoblog.com. Engadget and Autoblog are affiliated.

Comment 4

9 years ago
Autoblog and Engadget appear to work now with JIT turned on.

I am using:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080903034741 Minefield/3.1b1pre

Comment 5

9 years ago
Fwiw, the arm js_EqualStrings crash my group hit was caused by a jit misaligning something (execution? stack)

Comment 6

9 years ago
Ok, I will close this one. Please feel free to open a separate bug if the underlying cause of the other crash is still there (unaligned stack).
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 7

9 years ago
no patch->wfm
Resolution: FIXED → WORKSFORME

Comment 8

9 years ago
Engadget crashes again with JIT turned on.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081116 Minefield/3.1b2pre

Comment 9

9 years ago
Matt, could you file a new bug for this and link a crash report? And please cc me.

Updated

9 years ago
Flags: blocking1.9.1? → blocking1.9.1+
Crash Signature: [@ js_EqualStrings]
You need to log in before you can comment on or make changes to this bug.