Closed Bug 451903 Opened 13 years ago Closed 13 years ago

Build error in mailnews/mime with --enable-debug

Categories

(MailNews Core :: MIME, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.9.1a2

People

(Reporter: pi, Assigned: mnyromyr)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached file Build Error
When building Thunderbird with debugging enabled in Linux (Gentoo 2008 x86_64) I get the error shown in the attachment as of this morning.

Neil and jcranmer in IRC mentioned REQUIRES being incorrect in the mime makefile, so when I followed jcranmer's suggestion to add mailnews to REQUIRES in mime/build/Makefile.in I was able to build Thunderbird.  I can also build if I disable debugging.
IanN mentioned a similar problem in bug 366482 comment 14 - but in fact the patch of bug 366482 *is* the cause of this bug here:

changeset:   167:0137db13395c
user:        Ian Neal <iann_cvs@blueyonder.co.uk>
date:        Sat Aug 23 17:07:53 2008 +0100
summary:     Bug 366482 – "Edit as new" for opened eml files results in a broken compose window
=> doesn't compile with new objdir

changeset:   166:360c6d9b7341
user:        Magnus Melin <mkmelin@iki.fi>
date:        Sat Aug 23 13:56:32 2008 +0300
summary:     Followup nits from bug 297534 (Want to entirely disable marking a message as read when viewed), sr=neil
=> still compiles with new objdir
This makes /mime build again in my debug build. Since I don't do non-debug builds but IanN does, letting him have a look as well.
Assignee: nobody → mnyromyr
Status: NEW → ASSIGNED
Attachment #335252 - Flags: superreview?(neil)
Attachment #335252 - Flags: review?(iann_bugzilla)
(In reply to comment #2)
> Created an attachment (id=335252) [details]
> add building mailnews/ as a requirement to mime
> 
> This makes /mime build again in my debug build. Since I don't do non-debug
> builds but IanN does, letting him have a look as well.
> 
It's good that this fixes the issue but it would be good to know why a debug build requires this and a non-debug doesn't. Which bit of code is switched on in a debug build?
Attachment #335252 - Flags: review?(iann_bugzilla) → review+
Maybe we could figure out how to stuff the missing symbols into the msgbase lib, so that this fix here and yours in bug 366482 for cthandler are unnecessary?
Making them depend on /mailnews is rather messy...
Comment on attachment 335252 [details] [diff] [review]
add building mailnews/ as a requirement to mime (band-aid fix until bug 451988 fixes it for real)

Don't forget that non-debug builds default to static mail.
Attachment #335252 - Flags: superreview?(neil) → superreview+
Confirming on SeaMonkey and Windows, from bug 451871:
had same error, submitted same solution, asked same question, got same answer ;->
Blocks: 366482
OS: Linux → All
Hardware: PC → All
Created new bug 451988 for the move of MailNewsTypes* from mailnews to msgbase
Depends on: 451988
Comment on attachment 335252 [details] [diff] [review]
add building mailnews/ as a requirement to mime (band-aid fix until bug 451988 fixes it for real)

Landed on trunk.
Attachment #335252 - Attachment description: add building mailnews/ as a requirement to mime → add building mailnews/ as a requirement to mime (band-aid fix until bug fixes it for real 451988)
Not a dependency, just related.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
No longer depends on: 451988
Resolution: --- → FIXED
Attachment #335252 - Attachment description: add building mailnews/ as a requirement to mime (band-aid fix until bug fixes it for real 451988) → add building mailnews/ as a requirement to mime (band-aid fix until bug 451988 fixes it for real)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b1pre) Gecko/20080921023908 SeaMonkey/2.0a1pre] (home, debug default) (W2Ksp4)

V.Fixed
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla1.9.1a2
You need to log in before you can comment on or make changes to this bug.