Use quicksearch on format=guided bug-reporting page

RESOLVED INVALID

Status

()

bugzilla.mozilla.org
General
RESOLVED INVALID
10 years ago
7 years ago

People

(Reporter: Paul J. Weiss, Unassigned)

Tracking

({ue})

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: version 3.0.4+

The same search entered in the search box:
* at the top of the Bugzilla home page,
* in the middle of the Bugzilla home page ("Find a bug"),
* on the new bug reporting page
each retrieve a different result set. This is confusing, and probably leads to many duplicate bug reports. Either make the search algorithms the same, or make clear what the differences are.

Reproducible: Always

Steps to Reproduce:
As an example, do the following:
1. Enter "librar freez" in the search box at the top of the Bugzilla home page.
2. Enter "librar freez" in the search box in the middle of the Bugzilla home page ("Find a bug").
3. Enter "librar freez" in the search box on the new bug reporting page.
4. Compare results.
Actual Results:  
3 different search results sets

Expected Results:  
the same search result set

Comment 1

10 years ago
I hear ya, but this is actually a duplicate of some other bug I am sure. I'll leave it to LpSolit to mark it a dup of the right bug. But please know the bugzilla team is aware of this annoyance/weirdness.
Keywords: ue

Comment 2

10 years ago
This is probably also something that you're experiencing only on bmo, where the search boxes on the index page are not all the same.

Comment 3

10 years ago
In fact, all the places you mentioned are specific to bugzilla.mozilla.org. (Or at least, all the inconsistencies you mentioned.)
Assignee: ui → nobody
Component: User Interface → Bugzilla: Other b.m.o Issues
Product: Bugzilla → mozilla.org
QA Contact: default-qa → other-bmo-issues
Version: unspecified → other

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 428404
(Reporter)

Comment 5

10 years ago
This is not a duplicate of bug 428404. This bug is not about quicksearch per se, but that 3 search boxes that look similar yield 3 different result sets (regardless of whether or not the search is quicksearch).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to comment #0)
> The same search entered in the search box:
> * at the top of the Bugzilla home page,
> * in the middle of the Bugzilla home page ("Find a bug"),

These two are now the same (both quicksearch).

> * on the new bug reporting page

This one is not.

Gerv
Summary: seemingly identical searches entered in 3 places retrieve 3 different result sets → Use quicksearch on format=guided bug-reporting page
(Assignee)

Updated

7 years ago
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
the duplicate searching mechanism has been removed from the new guided bug entry form (see bug 657317).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.