password.value does not return anything, also input password shows real value instead of showing *'s

VERIFIED WORKSFORME

Status

()

Core
DOM: Core & HTML
P2
critical
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Prashant Desale, Assigned: jst)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
password.value does not return anything, also input password shows real value 
instead of showing value in "*'s".

And setting seviarity to critical because showing password real value is just 
against user password protection, and again most web developers use 
password.value put submit check.

STEPS TO REPRODUCE.
1] Visit above URL or load attachment I'm gonna provide.
2] you can see password input is showing value as real instead of showing it in 
*'s.
3] Click button "Show Password Value". [alert will pop up]

EXPECTED RESULTS:
Password value should be represented in *'s.
And after clicking button, pop up alert should show password value.

ACTUAL RESULTS:
Password value could be seen as real value in input password.
alert does not show password value.
(Reporter)

Comment 1

18 years ago
Created attachment 11263 [details]
testcase
(Reporter)

Comment 2

18 years ago
putting on nsbeta2 radar.
Keywords: nsbeta2
Priority: P3 → P2

Comment 3

18 years ago
It works for PDT today. Marking WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

18 years ago
Verified with 2000-08-09-08.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.