a['0'] does not equate to a[0] for dense arrays?!

RESOLVED DUPLICATE of bug 451906

Status

()

--
critical
RESOLVED DUPLICATE of bug 451906
10 years ago
10 years ago

People

(Reporter: brendan, Unassigned)

Tracking

Trunk
mozilla1.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
From Steven Roussey's comment in http://ejohn.org/blog/tracemonkey/:

var s=[1,2,3]
console.log(s['1'])

Sorry if this is a dup. Must fix!

/be
(Reporter)

Comment 1

10 years ago
Oops, I didn't quote Steve's results. From my own TM shell, no JIT:

js> var s=[1,2,3]
js> s['0']
js> 

undefined is the wrong answer, of course.

/be

Comment 2

10 years ago
(In reply to comment #0)

> Sorry if this is a dup.

Steve filed bug 451906.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 451906
You need to log in before you can comment on or make changes to this bug.