places.sqlite corrupted after installing add-in "FF Showcase"

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: Harry Kümel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Hi,

On Aug 24, I installed the add-in "Firefox Showcase" (or rather: I received a message asking to add this install this add-in.

After installation, everything seemed fine, except that after _each_ restart of FF an extra tab opened in the browser, which said that "Showcase" had successfully been installed + some ads for Google toolbar, etc.

Today, suddenly all my links, bookmarks and whatnot disappeared from the browser, then it began to act erratically, including an ex-tre-me-ly sloooooow exit (about 2 minutes) - which slowed down my whole system until that slooooow exit was over.

Oh yes: all my FF backups had disappeared too!

I went looking for some answers, but found none to my satisfaction. So I decided to desinstall FF and install it again - to no avail. The bug remained, getting worse than ever. So I decided to desinstall FF completely (including my precious bookmarks, setting, etc.) Prior to that, I backed up the whole AppDat Mozilla directory to another drive and, lo and behold! one file in the profile could not be copied due to the idiotically called cyclic redundancy error (which can mean anything, as everyone knows, ah! Microsoft!) And that winner was... places.sqlite.

I went on the lookout again in your bug reports. And indeed, countless users seemed to have been entangled with problems around that file. But none reported exactly the slings and arrows I was submitted to.

So I just tried something: I re-installed FF, but did not start it, went looking for that damned places.sqlite file, put it on my desktop (remaining in fact on the same drive) and fired up FF again. Double lo and behold! Everything was in order again, and as if by miracle, all my settings had returned. So, I took a look again in the profile directory, and there was a brand new places.sqlite file, far smaller than the corrupted that was there before (200 vs 5000 more or less).

So, please inform your users that there might be a very simple solution to a much reported problem - and to all intents, check that "Showcase" add-on...

Bye

Harry

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.
This sounds like a problem with that extension, not something we can fix here -> INVALID.

I recommend you comment with your problem on that extension's AMO page. I haven't heard any other complaints like this about Showcase though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.