no licensing information available about add-ons

VERIFIED DUPLICATE of bug 446361

Status

VERIFIED DUPLICATE of bug 446361
10 years ago
3 years ago

People

(Reporter: oliva, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008072301 Fedora/3.0.1-1.fc10 Firefox/3.0.1
Build Identifier: 

Chris Hoffman told me yesterday that there were efforts underway, or possibly already completed, to add licensing information to the web pages about individual add-ons, and to file a bug if it wasn't visible enough.

I couldn't find any licensing information whatsoever in a number of add-on web pages hosted at addons.mozilla.org.  It would be nice to not only have this information explicit in the web pages (say, if one wants to be selective as to accepting licensing restrictions in add-ons), but also that this was searchable.

Thanks,

Reproducible: Always

Steps to Reproduce:
1.Visit say https://addons.mozilla.org/en-US/firefox/addon/1865
2.Search for "licens" on the web page
Actual Results:  
No hits

Expected Results:  
Some statement as to the license/s under which this (and any other) add-on is available.

Some plugins actually mention licensing information on their sites, referenced from addons.mozilla.org, but many don't.  Many don't even have licensing information included in their sources, or in the .xpi binaries.  This exposes users to legal risks in countries where explicit permission is required to possess copies of software, or to run software.
See bug 330051 (I hope it ends better this time).

Comment 2

10 years ago
(In reply to comment #1)
> See bug 330051 (I hope it ends better this time).

Seconded!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: no licensing information available about plugins → no licensing information available about add-ons

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 446361
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.