Popup menus appears in wrong position if screen resolution changed after firefox started

RESOLVED DUPLICATE of bug 414844

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 414844
10 years ago
10 years ago

People

(Reporter: Sergei Delov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1

I use Linux Kubuntu.

By some reason (I suspect mulfunctioned Radeon 1950 Gt card driver with old CRT monitor) after boot screen has resolution 640x480. 

Firefox sometimes starts while the screen is still at that low resolution. 

I had to change resolution to the highest supported by the monitor - 1600x1200 while firefox is active.

Now, when I'm trying to use any popup menu od dropdown list (search engine dropdown list), it'll appear far away from the current position of the mouse pointer.


Reproducible: Always

Steps to Reproduce:
1. Verify firefox is not running
2. Change screen resolution to 640x480
3. Start firefox
4. Change resolution to the higher resolution, say 1600x1200
5. Open any site

Actual Results:  
1. Right click to any place in the window -- menu appears far away from the pointer position
2.  Click on the search engine dropdown list -- menu appears away from the pointer position.

Expected Results:  
All popup menu / drop down list should appear with the menu box top left corner positioned at the mouse pointer

Looks like popup menu/ dropdown list position is calculated using some initialized at firefox startup screen resolution values, "get current screen resolution" call is not performed for such calculations.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414844
You need to log in before you can comment on or make changes to this bug.