All users were logged out of Bugzilla on October 13th, 2018

Firefox silently fails if profile directory is unwriteable.

RESOLVED DUPLICATE of bug 448845

Status

()

RESOLVED DUPLICATE of bug 448845
10 years ago
10 years ago

People

(Reporter: bma, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME?)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008071420 Iceweasel/3.0.1 (Debian-3.0.1-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008071420 Iceweasel/3.0.1 (Debian-3.0.1-1)

If a ~/.mozilla directory exists but is not owned by the user (e.g. owned by root), Firefox fails to start but does not give an explanation.

Reproducible: Always

Steps to Reproduce:
1. Create a root-owned directory '.mozilla' in the current user's home directory, but without write permissions for the current user.
2. Start firefox.
Actual Results:  
Firefox silently fails to start.

Expected Results:  
Firefox should print a warning that it cannot start because it cannot write to the profile directory.

Updated

10 years ago
Whiteboard: DUPEME?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 448845
You need to log in before you can comment on or make changes to this bug.