Can't open ".URL" files in Firefox on the mac

RESOLVED DUPLICATE of bug 361847

Status

()

Firefox
Shell Integration
--
major
RESOLVED DUPLICATE of bug 361847
9 years ago
9 years ago

People

(Reporter: Scott, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: (I'm not on my mac right now, but it is running v2.0.0.16)

ok, I'll keep this brief as i'm sure you know what I'm talking about and
i'm sure i'm not the only one requesting/asking this.

I'm on the mac - 10.5.4. Why can't I open .URL files in firefox? For
example, I have a DELL PC running Firefox in XP. I drag a link from the
URL bar to the desktop of my dell. I then move those links to a flash
drive. I plug the flash drive in my mac and need to open the links. They
DO NOT open in firefox even if I force it. My solution is to open them
all in safari, then use the develop>"open in" command to open the safari
windows one by one in firefox.

Why can't FireFox handle .URL files?

Need more info, want me to explain more? let me know!

Please respond back!

Thanks!
Scott


Reproducible: Always

Steps to Reproduce:
I have a DELL PC running Firefox in XP. I drag a link from the
URL bar to the desktop of my dell. I then move those links to a flash
drive. I plug the flash drive in my mac and need to open the links. They
DO NOT open in firefox even if I force it. My solution is to open them
all in safari, then use the develop>"open in" command to open the safari
windows one by one in firefox.
Actual Results:  
Firefox won't open the .URL files. It gives me a dialog box to choose another application to open them in.

Expected Results:  
When I click on a URL file, Drag and drop a URL file on/in firefox, etc. it should open the same way a WEBLOC does.

This is a very common problem that not only happens to me, but I get questions all the time from OTHERS asking what to do, and I'm tied of telling them "you can't" also, many others have posted things on message boards trying to get help with this, but they are always ignored or un-answered. IT IS TIME TO FIX THE PROBLEM!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 361847
(Reporter)

Comment 2

9 years ago
Ok, so it "is" a duplicate, but it STILL HAS NOT BEEN SOLVED! Stop pushing us around to 3 different posts marking them all as done just because it is the same as what someone else asked....this is still an issue and it NEEDS to be fixed, and marking things done as a duplicate is not doing anything! 

Now if it was a duplicate, and you linked to the ANSWER or SOLUTION to this, then that is acceptable, but linking to someone else's question that is STILL un-answered - that is not right!
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
You, yes YOU must search before filing a bug if the bug already exists.
You either didn't do that or you didn't do that good enough because bug 361847 exists and you didn't found that. An older bug report means that you MUST NOT report this again.

You didn't find solutions here nor you find answers here, this is a bug database. This is also no end-user support Forum, this bug database and the bug database only exists for the developers not the users.
You as user can report bugs here if you follow a few rules : https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Reopening a bug is only permitted if the duping was incorrect but in this case it's the same bug report and that means that the mark as duplicate is correct.
The rules are simple: New bug reports are duped to the older one.
It doesn't matter if the old bug is 5 or 10 years old, read the etiquette again, if you want a bug to be fixed then attach a patch

Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 361847
(Reporter)

Comment 4

9 years ago
Ok, it IS A DUPLICATE, sorry - but when well it be a RESOLVED duplicate!?!

If you don't get your paycheck this week, then all next week your going to bug your boss until he gives it to you, right? Or are you just gona think, well its a known issue that he owes it to me, I better not re-sate the issue and let it go....

Ok, maybe that was a bad analogy, but what I'm saying is if you just FIXED the issue to begin with, no one would be RE-posted it over and over!

THANK YOU!
I live in germany and we don't get a check every week, we get once a month our the money on the bank account per wire transfer :-)

Creating a new bug report a new and open report report doesn't help at all, it creates only additional work for us.
If you want to get it fixed faster then attach a patch.
(Reporter)

Comment 6

9 years ago
Attach a patch? I don't know HOW to fix it, that is what this is for - to ask YOU GUYS to fix it! Again, I'm sorry for reposting this and to keep bring it up, but its something that needs to be fixed and I was hoping that it would be something you could start working on! I mean I wish I could help you guys with it since I want it done so bad, but I'm not that good at that kind of stuff! I'd be glad to TEST things for you though! Just let me know!
You need to log in before you can comment on or make changes to this bug.