Strings to localize for the "Firefox in your country" survey

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: pascalc, Unassigned)

Tracking

Details

Attachments

(7 attachments, 4 obsolete attachments)

(Reporter)

Description

10 years ago
Created attachment 335334 [details]
English strings to translate

We are organizing a survey for September on a few targeted locales titled "Firefox in your country". We thus need the survey to be localized for the following locales:

'de', 'en-GB', 'es-ES', 'id', 'pl', 'pt-BR'

You will find attached to this bug the text file to translate in a text editor.

Thanks
Created attachment 335345 [details]
es-ES translation for the survey (1st draft)

First draft of the es-ES translation. Either we will provide a better version, or we will confirm this one as the final valid version.

Comment 2

10 years ago
Created attachment 335381 [details]
Survey strings in pt-BR

Done for pt-BR 

[]s
de-DE is work in progress
(In reply to comment #3)
> de-DE is work in progress

We are still working on this. Please contact me on IRC (nick whimboo).
Created attachment 335573 [details]
de-DE translation

German translation - sorry, I was already done when I posted the WIP hint. I had only to take a break before checking the whole translation again.

Comment 6

10 years ago
Created attachment 335691 [details]
Polish translation

Done for pl.
Staś, please, review it.
Created attachment 335738 [details]
Revised es-ES translation
Attachment #335345 - Attachment is obsolete: true

Comment 8

10 years ago
There's a spelling error in the english version?
;Being aware of Firefox, but now knowing why it is unique or better

Shouldn't that be 'not' instead of 'now'?

Comment 9

10 years ago
Jesper: Definitely... thanks for pointing it out!
Jesper: good catch, thanks!

All: Thank you for your translations. I'll take care of the typo that Jesper found, so don't worry about you translated files :)
BTW. any news on Indonesian? :)
Depends on: 452738
Comment on attachment 335573 [details]
de-DE translation

All the work will be handled in bug 452738. We will attach the final version when it's ready.
Attachment #335573 - Flags: review?(hskupin) → review-
Attachment #335573 - Attachment is obsolete: true
Henrik, thanks for the update.

Comment 14

10 years ago
Created attachment 336232 [details]
[id] translation

Back from summer camp :)
Romi: thanks! Hope you had a good time :)

I'll put all the translations on the staging server tomorrow.  Thanks for all your work.
Created attachment 336692 [details]
Initial en-GB translation
Any updates on the German translation? :)
What's the death line for the translation? But it looks like that we will be ready soon.
Henrik, great to hear that. We'd like to go live with the survey on Tuesday, so it would be great to have the translation ready on Monday. Thanks!
Stas, that will be happen. But one question before we finish the translation. How should we include other countries like Austria and Switzerland? Currently the translation only appeals to German citizens.
Henrik, my initial answer is to leave "in your country" instead of "in Germany" in the affected strings. But let's ask Alix about it.

Alix: the survey tool can only detect the language of the respondent, not the country, so we can't have different translations for Germany, Austria and Switzerland. This means that people coming from for example Austria will see the page in German, but the survey title would be "Firefox in Germany". I think we could do "Firefox in your country" in this case instead. We will still be asking them to provide their country of origin, so we will be able to see separately how German, Austrian and Swiss users responded. What do you think?
(In reply to comment #20)
> Stas, that will be happen. But one question before we finish the translation.
> How should we include other countries like Austria and Switzerland? Currently
> the translation only appeals to German citizens.

After chatting with Alix we decided to keep "in Germany" version (as well as "in Spain" and "in Brazil"). The rationale is that we consider this survey a kind of a test-run, and eventually, we would like to extend to other countries as well. If we get people from these countries to take our survey right now, we loose the opportunity to survey them next time :) That's why we want to keep the message clear and explicitly invite in the title only residents of Germany (Spain, Brazil..) to the study. 

Does this make sense?
I'm fine with your decision. Let it be a test run and serve the other two countries at a later time. We will try to get it done this weekend. Perhaps it can be done during our meeting in Cologne.
That would be really cool. Please keep us updated :) Thanks in advance!
Created attachment 337403 [details]
German (de) localization v2

Looks like we are right in time with our translation.
Whoah, great news :) Thanks!
Created attachment 337405 [details]
Better en-GB l10n
Attachment #336692 - Attachment is obsolete: true
Seems like we're all set. Thanks to everyone for your help!
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Reopening for the following two strings:

pt-BR:
;12. Is there anything Mozilla should either start -- or stop -- doing to drive greater awareness, education, word-of-mouth or press in your market?

Indonesian (it wasn't originally in the file to translate, but it might be helpful):
;Other (please specify below)

If you guys could make it till tomorrow, that would be great :) Please add a comment to this bug with translation.

Other than that, check out the staging server at http://euro-surveys.php5stage.mozilla.com/?id=10 if you want to see your translation in action. 

Thanks again!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 30

10 years ago
Created attachment 337644 [details]
[id] translataion v2

Some corrections after checking stage server. Based on cf_question.lang file from r18094
Attachment #336232 - Attachment is obsolete: true

Comment 31

10 years ago
(In reply to comment #29)

stas, this is for [id]:

> ;Other (please specify below)
Lainnya (tuliskan di bawah ini)

Thanks!
Romi, awesome, thanks! :) comment 30 and comment 31 landed in r18107.
Filipe, would you find a minute to translate this sentence into pt-BR?

;12. Is there anything Mozilla should either start -- or stop -- doing to drive
greater awareness, education, word-of-mouth or press in your market?

(it's missing in the file)
OK, we managed to translate this sentence in the end. Big thank you to everybody!
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Why can Austria and Switzerland be selected for the survey in Germany at the bottom of the page? As you said above it should only be focus people from Germany?

Comment 36

10 years ago
stas, can we move the language selection to the top of the page

or

use flang form field using GET,so we can choose the language based on URL?

Indonesian people is mostly using en-US until now, and when they see [en] interface, there is no Indonesia country there. Telling them to scroll down first to change the language is not nice I think.
Hey Romi,

This is already implemented: http://surveys.mozilla.org/?id=10&plocale=id

However, I'm working right now on some better way of presenting the language chooser (like the top of the page), not sure if I'll manage to finish it today.

Thanks for feedback! ):
> Thanks for feedback! ):

Oops, I was too quick ;) That was supposed to be a smiling smiley, of course :)
(Reporter)

Comment 39

10 years ago
how about presenting the language switcher in a fixed positionned box on the right ?

Comment 40

10 years ago
(In reply to comment #37)
> Hey Romi,
> 
> This is already implemented: http://surveys.mozilla.org/?id=10&plocale=id

Thanks stas!
(In reply to comment #35)
> Why can Austria and Switzerland be selected for the survey in Germany at the
> bottom of the page? As you said above it should only be focus people from
> Germany?

Stas? Can I get a feedback plz?
Henrik, I'm sorry for replying with a delay.

We're getting lots of traffic from all over the world and many surveys have been taken by users who don't come from the six countries we selected. This is all very valuable feedback for us and having this question there will help us to determine which country the users were coming from. Does this answer your question? :)
Stas, IMO your latest comment conflicts with comment 22. Do you want to have users from other German speaking countries or not? I'm a bit curious.
Ideally, we'd like them to wait until we roll out similar surveys in their respective countries. But hey, this is the Mozilla community, always super eager to help out :) And we can't forbid them to take the survey :) So we're asking this additional question to know where they come from. I strongly believe that instead of removing this question, we should focus on communicating that the survey is in a test-run phase and that we're currently studying the German market (and that the others will follow).
(In reply to comment #39)
> how about presenting the language switcher in a fixed positionned box on the
> right ?

In the end, I made two language choosers (at the top and at the bottom), as well made sure that when changing languages, the selected answers are preserved during the reload of the page. 

Thanks for all the feedback. If you have other issues to report, please comment on bug 455404.
Alright. As I can see we will have a better recognition and could separate people from the other countries. That makes sense. Thanks Stas.
Sadly we used radio buttons for some answers. As we have heard from some users who has taken the survey there should be check boxes at least for the OS. No idea if it was intended to offer e.g. Windows *or* Linux in this survey.
You need to log in before you can comment on or make changes to this bug.