Command firing in Table submenus is intermittent

VERIFIED WORKSFORME

Status

()

P2
major
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: cmanske, Assigned: cmanske)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][p:2])

(Assignee)

Description

18 years ago
Sorry, this one is a pain, but I can't pin down any reproduceable case.
Start Composer, insert a table, put your caret inside the table, then execute
various Table submenu commands, such as Insert | Cell Before, or Delete | Cell.
Sometimes they work and sometimes they don't! I've put "dump" statements in our
JavaScript commands' 'doCommand' handlers, and also put break points in 
nsMenuFrame::Execute(), and sometimes the command is fired, and sometimes it
isn't! Delete Cell(s) seems to be the most reproduceable, but it may take 5 or 
so tries before you get a command failure. When the command fails to fire, the
focus is never returned to the page as it normally is when the command executes
correctly.
(Assignee)

Updated

18 years ago
Severity: normal → major
Target Milestone: --- → M17
(Assignee)

Comment 1

18 years ago
*** Bug 47044 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

18 years ago
This is critical and must be fixed -- commands are not working dependably.
Status: NEW → ASSIGNED
Keywords: correctness, nsbeta3
Target Milestone: M17 → M18

Comment 3

18 years ago
setting to nsbeta3+
Whiteboard: [nsbeta3+]
(Assignee)

Comment 4

18 years ago
*** Bug 48730 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

18 years ago
This has to be fixed. Currently, I don't have a clue why the commands fire
sometimes and not others.
Priority: P3 → P2
Whiteboard: [nsbeta3+] → [nsbeta3+][p:2]
(Assignee)

Comment 6

18 years ago
Sujay an I have been excersizing these commands and things seem ok now.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 7

18 years ago
verified in 8/31 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.