If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash forwarding IMAP message OR double clicking on draft or template msg [@ bridge_new_new_uri]

VERIFIED FIXED in M17

Status

MailNews Core
MIME
P3
normal
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Peter Trudelle, Assigned: rhp (gone))

Tracking

({crash, topcrash})

Trunk
x86
Windows 98
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+], crash signature, URL)

(Reporter)

Description

17 years ago
Using today's opt verification build on Win98, I crash immediately when trying 
to forward a message.  100% reproducible, stack is in talkback report at URL 
above.
(Assignee)

Comment 1

17 years ago
Investigating now.

- rhp
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Assignee)

Comment 2

17 years ago
*** Bug 45053 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Summary: Crash forwarding IMAP message → Crash forwarding IMAP message OR double clicking on draft or template msg

Comment 3

17 years ago
carrying forward the nsbeta2+ from 45053
Keywords: crash, nsbeta2
Whiteboard: [nsbeta2+]

Comment 4

17 years ago
Changing qa assigned to pmock@netscape.com
QA Contact: lchiang → pmock

Comment 5

17 years ago
This crash is one of the topcrashes in the recent builds.

Adding 'topcrash' keyword.
ccing chofmann and jpatel

Stack Trace: 
bridge_new_new_uri
[d:\builds\seamonkey\mozilla\mailnews\mime\src\nsStreamConverter.cpp
nsStreamConverter::SetStreamURI
[d:\builds\seamonkey\mozilla\mailnews\mime\src\nsStreamConverter.cpp
nsStreamConverter::Init
[d:\builds\seamonkey\mozilla\mailnews\mime\src\nsStreamConverter.cpp
nsStreamConverter::AsyncConvertData
[d:\builds\seamonkey\mozilla\mailnews\mime\src\nsStreamConverter.cpp
nsMsgDraft::ProcessDraftOrTemplateOperation
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgCreate.cpp
nsMsgDraft::OpenDraftMsg
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgCreate.cpp
nsMsgComposeService::OpenComposeWindow
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgComposeService.cpp
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp
nsXPCWrappedNativeClass::CallWrappedMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativeclass.cpp
WrappedNative_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp
js_Invoke       [d:\builds\seamonkey\mozilla\js\src\jsinterp.c
js_Interpret    [d:\builds\seamonkey\mozilla\js\src\jsinterp.c
js_Invoke       [d:\builds\seamonkey\mozilla\js\src\jsinterp.c
js_InternalInvoke       [d:\builds\seamonkey\mozilla\js\src\jsinterp.c
JS_CallFunctionValue    [d:\builds\seamonkey\mozilla\js\src\jsapi.c
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp
nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp
PresShell::HandleEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp
nsEventStateManager::CheckForAndDispatchClick
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp
nsEventStateManager::PostHandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp
nsView::HandleEvent     [d:\builds\seamonkey\mozilla\view\src\nsView.cpp
nsView::HandleEvent     [d:\builds\seamonkey\mozilla\view\src\nsView.cpp
nsView::HandleEvent     [d:\builds\seamonkey\mozilla\view\src\nsView.cpp
nsViewManager2::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp
HandleEvent     [d:\builds\seamonkey\mozilla\view\src\nsView.cpp
nsWindow::DispatchEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp
nsWindow::WindowProc    
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp
KERNEL32.DLL + 0x363b (0xbff7363b)
KERNEL32.DLL + 0x242e7 (0xbff942e7)
0x00688b46

    bridge_new_new_uri d397d434
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000070921 CrashDate: 2000-07-10 UptimeMinutes: 5  Total: 155 
        OS: Windows 95  4.0 build 67306684
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13905845

    bridge_new_new_uri fdbaec33
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071009 CrashDate: 2000-07-10 UptimeMinutes: 1  Total: 2 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: Double clicking draf
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13918407

    bridge_new_new_uri fdbaec33
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071009 CrashDate: 2000-07-10 UptimeMinutes: 1  Total: 1 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: Double clicking msg in Drafts folde
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13918404

    bridge_new_new_uri fdbaec33
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071009 CrashDate: 2000-07-10 UptimeMinutes: 17  Total: 31 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: Clicking on a different draf
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13920151

    bridge_new_new_uri 5c46c044
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071009 CrashDate: 2000-07-10 UptimeMinutes: 2  Total: 33 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: Double click on template ms
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13920154

    bridge_new_new_uri ee63c5a5
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071009 CrashDate: 2000-07-10 UptimeMinutes: 23  Total: 33 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: attempting to edit message as ne
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13935380

    bridge_new_new_uri ee63c5a5
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071009 CrashDate: 2000-07-10 UptimeMinutes: 3  Total: 37 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: Trying to edit as new again
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13935590

    bridge_new_new_uri d397d434
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071021 CrashDate: 2000-07-11 UptimeMinutes: 17  Total: 247 
        OS: Windows 95  4.0 build 67306684
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13968295

    bridge_new_new_uri d397d434
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071021 CrashDate: 2000-07-11 UptimeMinutes: 3  Total: 250 
        OS: Windows 95  4.0 build 67306684
        URL: 
        Comment: Doing a Forward As -> Inline for a HTML mail message when my
settings indicate to send text only
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13969099

    bridge_new_new_uri 8b4dd579
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071109 CrashDate: 2000-07-11 UptimeMinutes: 81  Total: 81 
        OS: Windows 98  4.10 build 67766222
        URL: 
        Comment: replying to an IMAP messag
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13987625

    bridge_new_new_uri 2ec4ce6e
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071109 CrashDate: 2000-07-11 UptimeMinutes: 329  Total: 337 
        OS: Windows NT  5.0 build 2195
        URL: mozmail/drafts folder
        Comment: double clicking on a draf
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13993308

    bridge_new_new_uri 8b4dd579
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071109 CrashDate: 2000-07-11 UptimeMinutes: 16  Total: 97 
        OS: Windows 98  4.10 build 67766222
        URL: 
        Comment: forwarding an IMAP messag
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13993334

    bridge_new_new_uri 02e3be47
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071109 CrashDate: 2000-07-11 UptimeMinutes: 0  Total: 338 
        OS: Windows NT  5.0 build 2195
        URL: mozmail/drafts folder
        Comment: select draft
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13993326

    bridge_new_new_uri 8b4dd579
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071113 CrashDate: 2000-07-11 UptimeMinutes: 1  Total: 1 
        OS: Windows 98  4.10 build 67766222
        URL: 
        Comment: pressing the toolbar "forward" button on MailNews to forward a
selected message
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13996180

    bridge_new_new_uri acd4458f
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071109 CrashDate: 2000-07-11 UptimeMinutes: 1  Total: 1 
        OS: Windows 98  4.10 build 67766222
        URL: 
        Comment: Double click on message in Drafts folder and crash
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13997904

    bridge_new_new_uri acd4458f
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/mime/src/nsStreamCo
nverter.cpp
line 131
        Build: 2000071109 CrashDate: 2000-07-11 UptimeMinutes: 1  Total: 2 
        OS: Windows 98  4.10 build 67766222
        URL: 
        Comment: reproducing crash: Double click on message in Drafts folder and 
cras
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=13997968

(Assignee)

Comment 6

17 years ago
Yes, this was a pretty severe problem. I have a fix for the crasher and I am 
working on some other broken logic in this file. I should be able to fix this 
when the tree opens.

- rhp
(Assignee)

Comment 7

17 years ago
*** Bug 45146 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
Adding topcrash keyword, this made it to the number 1 spot on the talkback crash 
list today.
Keywords: topcrash
Summary: Crash forwarding IMAP message OR double clicking on draft or template msg → Crash forwarding IMAP message OR double clicking on draft or template msg [@ bridge_new_new_uri]
(Assignee)

Comment 9

17 years ago
I think this should be all better now.

- rhp
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
Using the win32 (2000-07-24-21 M17), I do not see any crash using the same 
scenarios as described in the summary.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ bridge_new_new_uri]
You need to log in before you can comment on or make changes to this bug.