Status

Thunderbird
Folder and Message Lists
--
enhancement
RESOLVED WONTFIX
10 years ago
4 years ago

People

(Reporter: Sven Neuhaus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon idea])

(Reporter)

Description

10 years ago
I am proposing the following enhancement: 
A "delayed delete" function. The length of the delay can be configured by the user.

This function would help in reducing the amount of unimportant mails that I can't delete rightaway because I might need them in the near future in my inbox.

The idea is that you can of course stop the mail from being deleted before the delay ends if you change your mind.

Comment 1

10 years ago
We hav a delete confirmation window in the current trunk. I think that would fix this issue.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(In reply to comment #1)
> We hav a delete confirmation window in the current trunk. I think that would
> fix this issue.
> 
Tyler, I think you have misunderstood Sven's request. The request here could be for a delete delay of greater than a few moments, e.g. a few weeks. There have been various discussions about archiving, and this may come into play here.

I think its wrong in this case to mark wontfix without some discussion first.

cc'ing Bryan (our user experience person) for extra comment.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
we have bug 451995, which is about implementing an archive method for messages

However this request sounds more like a 30 day trash retention policy where messages older than 30 days are automatically deleted.  I do think that's a reasonable method for managing the Trash folder.
(Reporter)

Comment 4

10 years ago
Thanks. What I noticed was that I keep a lot of mails in my inbox because I might need them again in the near future. I do know, however that I won't need them later on.
I'd like to mark these messages for auto-deletion after a configurable interval. They should remain in the inbox for the time being, perhaps they could be displayed in grey instead of black.

What do you think?
I think that aligns well with the Trash policy.  AFAIK we have an option to not move trash to the Trash folder, but just mark it as trash.  I don't think we indicate trash messages in the inbox very well.  But I think this is how you could get what you're looking for in our current interface.

Comment 6

10 years ago
Should we mark as WONTFIX, that looks like where this is heading, IMHO?

Comment 7

7 years ago
Sven, so would this meet your needs - retention policy for mark as delete model, and only for those messages only, should be Trash's policy setting and not the inbox's retention policy.
(Reporter)

Comment 8

7 years ago
The difference between a delayed delete and messages in the trash that get deleted after a certain time period is that there is no difference between messages i delete normally and those i tag as "might need in the near future, if not, delete".

Comment 9

7 years ago
No sure that answers my question. But I don't think my initial thought would work for you :(  ... because if I understand correctly you're not using mark as deleted model, and you already use the trash folder for "immediate" deletes.  

Are you looking to for "deferred" messages to be deleted in fixed period of X days or months?  Or something more flexible, in other words assigning a *different* deletion time for each delayed message?  

Both cases could be done today (but with a manual step), using tags. For the fixed period case pick a tag A, create a filter defined as tag A, older than N days, action delete.  Then tag your messages, and run that filter once a day.

For the flexible deletion period - defined tags as "delete in June", "delete in ...", and then once a month delete all the messages tagged for deletion that month.  (and there's an addon that allows tagging messages using keyboard numeric of 2 digits, i.e. >9). You'd have to pick a granularity - monthly, quarterly, etc.
Component: General → Folder and Message Lists
OS: Linux → All
QA Contact: general → folders-message-lists

Comment 10

7 years ago
Sven, UNCOnfirming because the criteria of what you want and how this might be implemented are IMO not fully defined - more information is needed:

- which delete model?  mark as delete only? or both mark as delete and move to trash?
- are you wanting the delay value to be set per message, per folder, or per account?
- are you suggesting the delete key be used to initiate this or some other key
- using said key(s), do you have a suggestion of how to distinguish between deletes which should delayed (stay in the folder) and those which are immediate (eg. go to trash) - do you propose that delete key always prompts the user for a choice?
- do you have a suggestion of how a "delayed delete" message be shown in the message list (UI)?



IMO, based on current description of this issue, giving multiple levels of delete to all users will be very confusing to them.  I think a "cleaner" but perhaps less flexible solution is to use TAG, plus a manually run filter to delete tagged messages which are >N days old
Status: REOPENED → UNCONFIRMED
Ever confirmed: false
Whiteboard: [closeme 2011-05-01]
(Reporter)

Comment 11

7 years ago
I like your suggestion with tagging. I suppose an extension could implement this. Thanks.

Comment 12

7 years ago
(In reply to comment #11)
> I like your suggestion with tagging. I suppose an extension could implement
> this. Thanks.

Thanks. Interpreting your comment as withdrawing the request.  If that's not accurate, please comment, and provide more detail per comment 10.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago7 years ago
Resolution: --- → INVALID
Whiteboard: [closeme 2011-05-01] → [addon idea]

Comment 13

4 years ago
(this is more accurately wontfix)
Resolution: INVALID → WONTFIX
You need to log in before you can comment on or make changes to this bug.