Status

()

defect
--
major
RESOLVED DUPLICATE of bug 102695
11 years ago
11 years ago

People

(Reporter: davet, Assigned: roc)

Tracking

(Depends on 1 bug)

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
wanted1.9.1 -

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments, 1 obsolete attachment)

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Since I upgraded my Firefox earlier today, as per the notification that an upgrade was available, some drop-down menus no longer work. Example, the above webpage drop-down for Year was working perfactly before upgrade and no longer allows a selection.  It still works with IE, so it's not the website.  Interestingly, some drop-down menus from the main menu at the top of the webpage, work.

Reproducible: Always

Steps to Reproduce:
1.Stopped Firefox, re-started and same problem
2.Brought up same webpages on IE and it works perfectly
3.
Actual Results:  
open website www.regalboats.com
Under Navigate drop-down, select Archive
New screen populates and requests to select "Please chose a Year" on a drop-down menu.
No longer allows selection of the Year, but did before upgrade this morning

Expected Results:  
Should have dropped down and shown years 2007 2006 2005 2004 to select from
This is a regression from bug 317375.
Blocks: 317375
Needs QA love probably
Posted file testcase (obsolete) —
WFM on Mac. But dropdowns work differently there.
Component: Toolbars → Layout
Product: Firefox → Core
QA Contact: toolbars → layout
Version: unspecified → Trunk
Assignee: nobody → roc
Flags: wanted1.9.1?
Comment on attachment 335630 [details]
testcase

Arh, sorry, apparently something went wrong while minimizing, this is worksforme, too.
Attachment #335630 - Attachment is obsolete: true
Posted file testcase
I guess this is invalid.
Posted file testcase2
Well, I don't know. Please enlighten me.
I guess the relative positioned element creates a stacking context, so I guess it still needs to be on front of the normal div then.
http://www.w3.org/TR/CSS21/visuren.html#z-index
Ah, I see! Yeah, the <select> is actually under the enclosing <div>, so the enclosing <div> gets the mouse events. So our behaviour is correct, or at least not incorrect, per spec.

If we made elements transparent to events in some cases, that could "fix" this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Depends on: 102695
Resolution: --- → INVALID
Reporter

Comment 11

11 years ago
Wondering why this is marked as RESOLVED INVALID when in fact it is exactly the same problem today as yesterday, when I logged the bug.  It is NOT resolved and look forward to a resolution. Thanks Dave
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Because the webpage has layered an invisible element on top of the drop down list meaning that the list doesn't get any mouse clicks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 102695
Flags: wanted1.9.1? → wanted1.9.1-
You need to log in before you can comment on or make changes to this bug.