Closed Bug 452234 Opened 12 years ago Closed 10 years ago

Easier set and display of priority/status for events and tasks

Categories

(Calendar :: Calendar Views, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 340025

People

(Reporter: misterbinz, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Lightning 0.9pre build 2008081018

I think the priority & status parameters (event, task) deserve a better visibility within edit windows & calendar view.

It's currently only available within the menu, and doesn't imply anything in Calendar view, except a lower display priority (eg two concurrent events, a cancelled one will be on the right of a confirmed one).

The Edit window could be changed by either :
- adding a dropdown list
- or a taskbar button calling a dropdown (just like the current privacy setting)

Concerning the calendar view, the priority could be set by an upwards or downwards arrow (resp. high and low priorities).
About event status (or "show time as" option), Outlook uses a left-hand bar that displays a different color according to that status. This idea could be re-used, or maybe a different color shading (just like a disabled button, for instance).

So far, I haven't found a similar RFE (or bug report) : apologies if there is. Since this request is about two concurrent things (edit & display), maybe it should be split in two.

Reproducible: Always
OS: Windows XP → All
Summary: [RFE] Easier set and display of priority/status for events, tasks → Easier set and display of priority/status for events and tasks
The issue is contained in bug 273279 and bug 340025
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 340025
You need to log in before you can comment on or make changes to this bug.