when searching in History sidebar "By Last Visited" results are listed in Alphabetical Order

RESOLVED DUPLICATE of bug 392497

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 392497
10 years ago
9 years ago

People

(Reporter: Tom Yates, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

History->By Last Visited

The pages are listed in Alphabetical Order, not by Last Visited.

e.g., I want to search for bugs in my bug database, so I type ABCD as my bugs are all called ABCD-xxxx

However, I get them listed in 1, 2, 3, 4 order instead of the order I last visited them in.

This makes it impossible to use history for this purpose as I have visited many thousands of these named pages.

Reproducible: Always

Steps to Reproduce:
1.  Visit three pages NOT in alphabetical order
2.  Go to history->by last visited
3.  Pages listed in alphabetical order, not be last visited


Expected Results:  
Pages should be listed in the order visited
(Reporter)

Comment 1

10 years ago
Sorry, after checking more, this bug IS ONLY SEEN when you type something in the search bar.

i.e.

Visit pages
Bug 1
Bug 3
Bug 2

Go to History->By Last Visited
Bug 2
Bug 3
Bug 1 (Correct)

Type 'Bug' into the search bar at the top
Bug 1
Bug 2
Bug 3 (Incorrect)

Sorry for this slight mistake in the report

Updated

9 years ago
Summary: Pages in History->By Last Visited are listed in Alphabetical Order, not by Last Visited. → when searching in History sidebar "By Last Visited" results are listed in Alphabetical Order

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392497
You need to log in before you can comment on or make changes to this bug.