saving the install file to then run fails or running the install file that downloaded to run also fails.

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: krnjin, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: file version 4.42 firefox version 3.0.1

I had no version of Firefox on the computer after a fresh install on windows.  Downloaded firefox 3.0.1 to replace windows internet explorer.  Tried saving the file, run the install file, message box appears saying "Extraction failed", "File is corrupt".  Tried re-downloading it via the link provided if the automatic download didn't work and choose to to a run of the install file and still got the same message of "Extraction failed", "File is corrupt".  Can be re-produced by either redownloading the file or re-running the file from the link and the install exits without even coming up.

Reproducible: Always

Steps to Reproduce:
1. run windows xp service pack 2
2. open windows internet explorer
3. go to link to download firefox 3.0.1
4. download / run .exe file
5. fails with message box title "Extraction failed" and body text of "File is corrupt"
Actual Results:  
nothing special to do, just run the .exe and it will fail each and every time!

Expected Results:  
Message box with only an 'ok' button with the error message and setup exits without even starting

install this version of firefox so i could stop using internet explorer and start surfing the web (this bug report filed under internet explorer, very sad)
Sounds like your download is corrupt which can be caused by the server, the client used to download, anti-virus software some of which have been known to modify the file when it is downloaded, etc.

Can you try the following installer?
http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.0.1/win32/en-US/Firefox%20Setup%203.0.1.exe
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 2

10 years ago
the new link worked without any problem, the original link used took me to a different place but part of the mozilla.org site and that is where i failed before, thanks for the better link, this new file worked.
Over to mozilla.org -> FTP: Mirrors
Component: Installer → FTP: Mirrors
Product: Firefox → mozilla.org
Version: unspecified → other
You need to log in before you can comment on or make changes to this bug.