Last Comment Bug 452332 - Tab opens in wrong window (the first openned) when using window.open
: Tab opens in wrong window (the first openned) when using window.open
Status: RESOLVED DUPLICATE of bug 626365
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: 3.6 Branch
: x86 Windows XP
: -- major with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Dão Gottwald [:dao]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 17:17 PDT by Rodrigo Mello
Modified: 2012-06-07 09:25 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Rodrigo Mello 2008-08-26 17:17:45 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16

On Firefox 2, when a script used window.open('y.html') or <a href='y.html' target='_blank'> and the current window was oppenned using window.open('x.html', 'name', 'width=200,heigth=200'), the page oppenned in a new tab on the current window. Now on Firefox 3, the tab oppens on the first window. I develop a software that uses that behavior to group the related navigation tabs and limited my software to run on Firefox. Please, change the behavior to work as like the Firefox 2, because it is stealing me some sleep hours. 

Thank you.
Rodrigo Mello

Reproducible: Always

Steps to Reproduce:
1. Open a new window with window.open('x.html', 'name', 'width=200,heigth=200')
2. Open a new tab on the current "name" window window.open('y.html') or <a href='y.html' target='_blank'>
Actual Results:  
The new tab oppens on the parent window, not on the current window as on Firefox 2

Expected Results:  
Open the tab on the current window

None - basic installation
Comment 1 john lovely 2008-11-16 05:04:59 PST
I use a site which (I guess) relies on this same feature and Firefox 3.0 is a disaster - ALMOST as bad as IE.

I fixed it by deleting Ver 3 and just use Firefox 2.0.

Is there reaaly any reason to use 3.0?
Comment 2 Seth Green 2010-06-22 09:17:51 PDT
I've observed this exact behavior on FF 3.6.3 MAC. See example of the behavior here -> http://fattymelt.com/examples/WindowA.html
Comment 3 Tim Lamballais 2011-05-06 07:23:30 PDT
Strangely, I've been having this problem since upgrading from FF3.6 to FF4.
Comment 4 Alfredos-Panagiotis Damkalis [:fredy] 2011-06-07 23:43:01 PDT
I confirm this bug too at:
Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Comment 5 Alfredos-Panagiotis Damkalis [:fredy] 2012-06-07 09:25:45 PDT

*** This bug has been marked as a duplicate of bug 626365 ***

Note You need to log in before you can comment on or make changes to this bug.