inconsistent localization when indicating day of download in download manager

RESOLVED DUPLICATE of bug 419220

Status

()

Firefox
General
--
trivial
RESOLVED DUPLICATE of bug 419220
9 years ago
9 years ago

People

(Reporter: Juerg Ritter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

I'm running the english version of Firefox on an english Windows xp. The regional setting of Windows is set to German (Swtzerland). The Firefox download manager indicates day of download in english, if it's today or yesterday, but in german, if it's indicated as a weekday or month.

Reproducible: Always

Steps to Reproduce:
1. set windows regional option to another language than the language of firefox
2. download any file using download manager. do not clear list in download manager.
3. download another file a couple of days later
Actual Results:  
foo.pdf        Today
bar.pdf        Yesterday
foobar.pdf     Dienstag

Expected Results:  
(in language of firefox):
foo.pdf        Today
bar.pdf        Yesterday
foobar.pdf     Tuesday

(or in language set by windows):
foo.pdf        Heute
bar.pdf        Gestern
foobar.pdf     Dienstag
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419220
You need to log in before you can comment on or make changes to this bug.