Closed Bug 452460 Opened 11 years ago Closed 10 years ago

Mailer is started upon migration Wizard although my default in 1.x seamonkey profile was a browser

Categories

(SeaMonkey :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: mmokrejs, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.2pre) Gecko/2008082711 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.2pre) Gecko/2008082711 SeaMonkey/2.0a1pre

With current TRUNK build, seamonkey starts migration wizard when there is no ~/.mozilla/seamonkey/. After finishing the conversion and fired up two password-prompting windows. I did/do have 2 email accounts configured with POP3 so was not that much surprised. One of the windows was labeled that it is asking for a password for account xxx@aaa.bb while the other lacked any description in the Title bar.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 4.3.1 (Gentoo 4.3.1-r1 p1.1) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -Wno-long-long -pedantic -fno-strict-aliasing -pthread -pipe
c++ 	gcc version 4.3.1 (Gentoo 4.3.1-r1 p1.1) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-long-long -pedantic -fno-strict-aliasing -fshort-wchar -pthread -pipe

Configure arguments
--disable-optimize '--enable-debug=-g3\ -O0\ -ggdb' --enable-debug-modules=all --enable-debugger-info-modules --enable-detect-webshell-leaks --enable-svg --enable-svg-renderer-libart --enable-image-decoders=all --with-qtdir=/usr/qt/3 --enable-application=suite --disable-freetype2 --enable-jprof --enable-default-toolkit=cairo-gtk2 --enable-xft --disable-gssapi
Assignee: nobody → general
Component: Migration → General
Product: Thunderbird → SeaMonkey
QA Contact: migration → general
What does the bug summary have to do with your bug description? Maybe you can change your bug summary to match the actual bug description.
Well, it is really about mailer being started, and as a proof I take those two password prompting windows. That one of them lacked any text in the Title bar ... I don't care at the moment.

Please, take into the account it was a current snapshot from CVS, but at the moment you use different repository I have heard. :(
Ah, ok. I thought your problem was that one dialog has no description in the title.
Yes, we migrated to Mercurial, we no longer use CVS on trunk.
No longer blocks: 398944
Martin, the starting of the mailer component is actually on purpose. If you do not want that you can deactivate that behavior under Preferences, Mail & Newsgroups, Only check for new mail after opening Mail & Newsgroups.

Resolving INVALID (it's not a bug, it's a feature).

P.S.: This has nothing to do with migration. The same applies to a new profile once you create MailNews accounts there that should be checked by default.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.