Fixed height scrollable tbody with alternating colored rows overflows outside of table

RESOLVED DUPLICATE of bug 423823

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 423823
10 years ago
10 years ago

People

(Reporter: Matt Steitle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

I have a table inside of a div.  This table has a color applied to every even row via class="even".  The height of the tbody is determined on page load, if the table has more than 10 rows, to be the height of 10 rows.  The result is that the tbody will appear to continue on past the end of the table and superimpose the alternating colored rows (with no data) over whatever page content exists following the table.

Reproducible: Sometimes

Steps to Reproduce:
1. Create a table as described above.
2. Load page
3. Look at table
Actual Results:  
The blank alternating color table rows

Expected Results:  
Rendered the table normally; all rows displaying inside the confines of the table space.
can you provide a testcase and attach it to this bugreport, please?
(Reporter)

Comment 2

10 years ago
Created attachment 335754 [details]
Screenshot of problem

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 423823
You need to log in before you can comment on or make changes to this bug.