flash isn´t working if doctype forces strict render mode.

VERIFIED DUPLICATE of bug 46569

Status

()

Core
Plug-ins
P3
major
VERIFIED DUPLICATE of bug 46569
18 years ago
17 years ago

People

(Reporter: Martin Horwath, Assigned: av (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
expected result: you see a flash animation
actual result: i don´t see a flash animation

when i remove the DOCTYPE -> flash animation is displayed.

please make flash also work in standard render mode.
html for flash is generated from dreamweaver (i haven´t changed a bit).

tested on win95 with buildid 2000071020.

Comment 1

18 years ago
i can't seem to connect to the url u mentioned. could u pls attach a testcase 
page that i can download and see? thnx.
(Reporter)

Comment 2

18 years ago
sure , i generate a zip file...
(Reporter)

Comment 3

18 years ago
Created attachment 11292 [details]
working(without doctype) and non working version

Comment 4

18 years ago
Thanks for the testcases. The flash movie does not work if the following 
statement is put in the webpage.(testcase : not_working.html)

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
  "http://www.w3.org/TR/REC-html40/loose.dtd">

But if I remove the url in the "<Doctype>" , then it works fine.

Comment 5

18 years ago
Horwath: Your HTML is not valid. HTML 4.0 has no tag "EMBED". Thus, I am not
sure it is a bug that this is not working.

shirang: I think he knows that. IIRC, the URL forces standard mode, and that's
what he's trying to do.
(Reporter)

Comment 6

18 years ago
i know that -> but without that embed it would not work in ns4
the other option i have is : only use object -> works in ie and also should! 
work in mozilla but will not work in ns4.
how else should i generate cross browser compatible html. ooh wait..ns4 is dead
it is impossible to generate pages without unknown tags -> mozilla will display 
nothing :-(. why does mozilla not just ignore those tags ? or should i generate 
the right html with javascript ? what if the user has disabled javascript ? why 
should i use quirk mode -> nobody needs ns4 table rendering bugs but wait... 
flash works correctly.

the main reason why is use a standard mode is i want to see, how mozilla 
renders. 
if you think: accept only pure html 4 is the right way close this bug as 
invalid but please explain how to get flash working in standard render mode.

Comment 7

18 years ago
I think if you want standard mode, you'll need valid markup. I suspect that the
standard mode is tossing out your (invalid) EMBED tag.

Does the flash movie work in the standard document if you take out the EMBED
tag? If not, that is pretty certainly a bug.

(I thought NN4 understood OBJECT for plugins...)
(Reporter)

Comment 8

18 years ago
when i remove the embed tag it also does not work on mozilla. nice effect is it 
does not work anymore on ns4.
(Reporter)

Comment 9

18 years ago
there is also another description (i think a better one) in bug 44993.

(Assignee)

Comment 10

18 years ago
*** Bug 40851 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 11

18 years ago
is 46569 a dup or does it dependent on that bug ?
(Reporter)

Comment 12

18 years ago
i have two new testcases, forget the first attachment.
(Reporter)

Comment 13

18 years ago
Created attachment 14691 [details]
testcase with object type="application/x-shockwave-flash"
(Reporter)

Comment 14

18 years ago
Created attachment 14692 [details]
testcase with classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
(Reporter)

Updated

18 years ago
Summary: flash isn´t working if doctype forces standard render mode. → flash isn´t working if doctype forces strict render mode.

Comment 15

18 years ago
Seems like this has morphed into bug 46569...
(Reporter)

Comment 16

18 years ago
you´r right sean...

*** This bug has been marked as a duplicate of 46569 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 17

17 years ago
Verifying as a duplicate of bug 46569 
'OBJECT tag does not work for plugins if classid attribute is specified'
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.