Closed Bug 452554 Opened 12 years ago Closed 11 years ago

Hebrew GMail crash in [@ JS_XDRNewMem](Mac) / [@ FlushNativeStackFrame](Win) with JIT enabled

Categories

(Core :: JavaScript Engine, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: yehudab, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1a2pre) Gecko/20080827061345 Minefield/3.1a2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1a2pre) Gecko/20080827061345 Minefield/3.1a2pre

After setting the prefered display language of my GMail acount to Hebrew, and turning on JavaScript JIT any attempt to access GMail causes Firefox to Crash after the login screen. 

Reproducible: Always

Steps to Reproduce:
1. Install nightly build from Aug 22, 2008 or later
2. In about:config set javascript.options.jit.content to "true"
3. Login to your GMail account
4. Click on the top "Settings" link, and change "Gmail display language" to "Hebrew"
5. Save your changes 
Actual Results:  
Browser crash

Expected Results:  
GMail should display in Hebrew

Crash reports:
http://crash-stats.mozilla.com/report/index/ae2a9dd4-74b1-11dd-a29b-001a4bd43ef6
http://crash-stats.mozilla.com/report/index/9fb304dc-74b1-11dd-93de-001a4bd43ed6
Dup of bug 452283?

/be
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 452283
(In reply to comment #1)
> Dup of bug 452283?
> 
> /be
> 
> *** This bug has been marked as a duplicate of bug 452283 ***
> 
I've verified that this bug also happens on Windows. This means that it is not a dup of bug 452283 which is Mac OS X only (At least I could not reproduce 452283 on Windows).

This is the Windows crash report:
http://crash-stats.mozilla.com/report/index/652b3d0c-74c8-11dd-85fc-001a4bd43e5c
Status: RESOLVED → UNCONFIRMED
OS: Mac OS X → All
Hardware: Macintosh → All
Resolution: DUPLICATE → ---
Updated title with Windows crash signature.
Summary: Hebrew GMail crash in JS_XDRNewMem with JIT enabled → Hebrew GMail crash in JS_XDRNewMem(Mac) / FlushNativeStackFrame(Win) with JIT enabled
Summary: Hebrew GMail crash in JS_XDRNewMem(Mac) / FlushNativeStackFrame(Win) with JIT enabled → Hebrew GMail crash in [@ JS_XDRNewMem](Mac) / [@ FlushNativeStackFrame](Win) with JIT enabled
Keywords: crash
I'm seeing this also, but I wonder if it's the same as bug 451963.
Status: UNCONFIRMED → NEW
Ever confirmed: true
No crash using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080924033412 Minefield/3.1b1pre

Can you check using the latest nightly?
(In reply to comment #5)
> No crash using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre)
> Gecko/20080924033412 Minefield/3.1b1pre
> 
> Can you check using the latest nightly?

Well, the bug is not repeatable with the process described above. It is, however, because of a change in Hebrew Gmail code, and not because of a fix to Tracemonkey. The original crash can be reproduced when user selects Gmail's earlier version link ("גרסה מוקדמת" in Hebrew), or using this link: http://mail.google.com/mail/?ui=1

Here is a new crash report: http://crash-stats.mozilla.com/report/index/91e05319-8a63-11dd-afbf-001a4bd43ef6

Tested with: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b1pre) Gecko/20080924020442 Minefield/3.1b1pre
(In reply to comment #6)
Important addition: Looks like Gmail's earlier version link: http://mail.google.com/mail/?ui=1 crashes even if Gmail display language is set to English(US).
(In reply to comment #7)
> (In reply to comment #6)
> Important addition: Looks like Gmail's earlier version link:
> http://mail.google.com/mail/?ui=1 crashes even if Gmail display language is set
> to English(US).

I can confirm the crash just by going to http://mail.google.com/mail/?ui=1.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080924033412 Minefield/3.1b1pre

http://crash-stats.mozilla.com/report/index/2b62deba-8a63-11dd-9097-0013211cbf8a
I can not repro anymore with the recent nightlies, even following the link to the older version
Yehuda, are you still seeing this bug in more recent nightlies?
(In reply to comment #10)
> Yehuda, are you still seeing this bug in more recent nightlies?

Looks like this is fixed. Checked with this version:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b3pre) Gecko/20090111 Shiretoko/3.1b3pre

I will also confirm with the Hebrew version later on
Hebrew version also works fine. Verified with version:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; he; rv:1.9.1b3pre) Gecko/20090112 Shiretoko/3.1b3pre

I guess that the bug can be closed now.
(In reply to comment #12)
> Hebrew version also works fine. Verified with version:
> Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; he; rv:1.9.1b3pre)
> Gecko/20090112 Shiretoko/3.1b3pre
> 
> I guess that the bug can be closed now.

WFM per comment #12.
Status: NEW → RESOLVED
Closed: 12 years ago11 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ JS_XDRNewMem] [@ FlushNativeStackFrame]
You need to log in before you can comment on or make changes to this bug.