Clobbering "Linux comm-central build" by thunderbuild doesn't seem to work

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: standard8, Assigned: gozer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
I'm not sure if this applies to just Linux or not, I wanted to force a clobber to try and pick up some ifdef changes and generate a correct application.ini.

I tried saying to thunderbuild:

force build "Linux comm-central build clobber"

and got back the response:

<thunderbuild>	build #3 forced
<thunderbuild>	I'll give a shout when the build finishes

but didn't get any more than that (which I put down to the fact the clobber builds are "hidden".

Firing off new builds (either via clobbers or m-c checkins) the logs clearly showed they were dep builds rather than clobber builds.

Not a high priority but would be useful to fix at some stage.
(Reporter)

Updated

10 years ago
Priority: -- → P3
(Assignee)

Comment 1

10 years ago
Yes to the first thing. Seems that hiding builders from the IRC bots lets you ask for them specifically, but results will not be reported over IRC. So the statement 'I'll give a shout...' is just a buildbot lie, grr.

About not performing a clobber, I am not sure. I've looked at the buildbot logs for that build #3 and I can see it did rm -rf /builds/buildbot/comm-central-linux/build/objdir-tb

Is that not enough ? Does 'clobber' needs to do something else as well ?
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Yes to the first thing. Seems that hiding builders from the IRC bots lets you
> ask for them specifically, but results will not be reported over IRC. So the
> statement 'I'll give a shout...' is just a buildbot lie, grr.

Well I can cope with that now I know :-)

> About not performing a clobber, I am not sure. I've looked at the buildbot logs
> for that build #3 and I can see it did rm -rf
> /builds/buildbot/comm-central-linux/build/objdir-tb
> 
> Is that not enough ? Does 'clobber' needs to do something else as well ?

Well the log of the build after that didn't look like a full rebuild, I'd have expected it to be a lot longer. I guess you haven't got ccache or anything running on that?
(Assignee)

Comment 3

10 years ago
No ccache enabled on that box yet. Care to tell me what didn't look right ?

From the look of it, all clobbering did was wipe the objdir.
(Assignee)

Comment 4

10 years ago
Doh, I take that back, I know what the problem is, and I'll have it fixed in a moment. I can see from the logs that the build step didn't even go thru configure and ended up just doing make -C objdir-tb, obviously showing it hasn't been deleted.

http://hg.mozilla.org/build/buildbot-configs/rev/258

changeset:   258:3ef2fe6cba45
tag:         tip
user:        Philippe M. Chiasson <gozer@mozillamessaging.com>
date:        Fri Aug 29 18:12:16 2008 -0400
summary:     Bug 452583. Un-break clobbering for regular builds.
(Assignee)

Comment 5

10 years ago
Forced a clobber of the nightly build, and looks like it worked as expected, and took quite a long time.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.