When inserting a numbered list into any rich-text control, the number is always exposed as 0.

RESOLVED DUPLICATE of bug 557795

Status

()

Core
Disability Access APIs
RESOLVED DUPLICATE of bug 557795
10 years ago
8 years ago

People

(Reporter: MarcoZ, Unassigned)

Tracking

(Blocks: 1 bug, {access})

Trunk
x86
Windows XP
access
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

STR:
1. Start a current Shredder (Thunderbird 3) build.
2. Compose a new message.
3. Make sure under Tools/Encoding, Rich-Text (HTML) or "Both Rich-.Text and Plain Text" is selected.
4. Choose Format/List Style/Numbered.

Result: The first list item is created. Visually it is preceeded by the number "1.". However, when looking at the hierarchy using AccProbe, I see:

- List
- - ListItem[1]
- - - StaticText with a name of "0"
- - - Text with nothing or the entered text.

5. Type in something, and press ENTER. A new item is created, preceeded by "2.".

Result: In accessibility, another list item was appended, but its static text child is also given a name of "0". Also, the previous one did not get updated. In effect, a11y shows 2 numbered list items whose number is 0.

Comment 1

10 years ago
Is this a regression? 
Correction to the above, this also reproduces for me in Firefox using the WordPress Rich-Text editor which is based on TinyMCE. The steps are roughly the same:
1. Start a new post.
2. Insert an ordered list.

Observe that the "label" element that preceeds the actual text is always "0". Question: Why is it a label here and not statictext?
Summary: When inserting a numbered list into a Thunderbird rich-text message, the number is always exposed as 0. → When inserting a numbered list into any rich-text control, the number is always exposed as 0.

Updated

9 years ago
Blocks: 512196
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 557795
You need to log in before you can comment on or make changes to this bug.