If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Browser scrollbars resist scrolling

RESOLVED DUPLICATE of bug 445416

Status

()

Core
Widget
RESOLVED DUPLICATE of bug 445416
9 years ago
9 years ago

People

(Reporter: Hermann Schwab, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080827031643 Minefield/3.1a2pre
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080827001847 SeaMonkey/2.0a1pre

Bug not seen in 1.9.0 branch or 1.8 branch

Saw it first on vertical scrollbar, but also could it produce on horizontal scrollbar.

Steps to repeat:
1. Try scrolling down by clicking on top arrow and dragging it down: doesn't work
2. Then click on slider and drag it down: works, but when you release it, it scrolls automatically up.
3. Stop movement by clicking on up or down arrow of the scrollbar, doesn't matter which.

better Steps to repeat:
1. drag sliders somewhere in the middle of the scrollbars.
2. click an arrow of a scrollbar, drag it into the scrollbar area before releasing it. The slider starts scrolling towards the arrow.

Old bugs may be related:
Bug 157123 – Browser scrollbars continue scrolling after I release mouse button
Bug 420944 – If top scroll bar arrow held too long, page will automatically scroll to top and not scroll down 
Bug 442130 – scroll bar works incorrently

Relevance of the bug:

Annoying.

Found it because under some lighting conditions (bright sun) the exact position of the mousepointer isn't very visible on my display, so I by chance I tried to drag the arrow instead dragging the slider.

People seeing this bug don't see how it comes up or can be stopped, most simple workaround is reload.

Comment 1

9 years ago
Try the next nightly build as bug 445416 was just fixed.
(Reporter)

Comment 2

9 years ago
verified fixed by bug 445416

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080829003148 SeaMonkey/2.0a1pre
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 445416
You need to log in before you can comment on or make changes to this bug.