Closed Bug 4527 Opened 21 years ago Closed 20 years ago

form elements layout poorly in this table

Categories

(Core :: Layout: Tables, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: cmaximus, Assigned: karnaze)

References

()

Details

(Whiteboard: [TESTCASE] Dylan_G@bigfoot.com Layout of forms with <NOBR> appears broken.)

Build ID =1999040323 Windoze only.

To reproduce go to www.earthlink.com and look at the top of the page just below the adbanner, or clcik the url above(coming
soon) to see the min html.

Layout is difficult to say in words but basically the form elements should be layed out side by side in the same row. Instead they
are stacked on top of each other in pairs.
QA Contact: 4110 → 4137
adding testcase like i said i would
Status: NEW → ASSIGNED
Target Milestone: M7
Moving to M7.
Moving to M9.
Whiteboard: [MAKINGTEST] Dylan_G@bigfoot.com
Whiteboard: [MAKINGTEST] Dylan_G@bigfoot.com → [TESTCASE] Dylan_G@bigfoot.com Layout of forms with <NOBR> appears broken.
http://www.thock.com/thock/test_case.html
Illustrates the issue nicely.
The for is NOBRed properly, but it is shifted outside of the main window.  There
is no horizontal scrollbar visible, as well, so this is more problematic than a
cosmetic issue because it could stop some form usage.
Target Milestone: M9 → M10
Moving to M10.
Spoke to karnaze during bug triage today.  Moving to M11.  Not an M10 blocker.
Moving to M13.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
The form elements are now being layed out side to side (probably due to 11/5
changes). However, the form controls and their labels are not valigned the same.
I'm not sure if this is a problem in line layout or the style system. I will
open a new bug.
Bug 18192 has been opened regarding the valignment.
Status: RESOLVED → VERIFIED
http://mobay/bugs/bug4527.html looks the same under the 1999110809 build and Nav
4.7 on NT 4 - I'm marking this verified.
You need to log in before you can comment on or make changes to this bug.