Lightning custom repeat gives wrong dates and does not show settings when editing

RESOLVED DUPLICATE of bug 386516

Status

RESOLVED DUPLICATE of bug 386516
10 years ago
10 years ago

People

(Reporter: njsharp, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: version 2.0.0.16 (20080708) and Lightning 0.8

Environment: WXP SP2 Thunderbird 2.0.0.16 Lightning 0.8

Problems: 
* error in setting up custom reoccurring events
* failure to show already chosen custom repeat settings when editing the reoccurring event
* custom preview not scrollable to view long off repeats

Attempted to set up events to remind me to pay my local government charges due quarterly on 2008-Aug-31, 2008-Nov-30, 2009-Feb-28, final 2009-May-31.

Created custom re-occurring event at 2008-Aug-31 as follows:
repeat: [monthly]
every: [3] months
The [last][day of the month]
Create: [4] appointments

Preview (which SHOULD be scrollable and isn't) shows 2008-Aug-31 and 2008-Oct-31 instead of 2008-Nov-30 (which would be off the preview anyway).
OK then save and close shows 4 appointments (good) but on Aug 31 (good) and Oct 31 then Jan 31 then April 30 (bad bad bad)
An attempt to edit the entry at Aug31 (all occurrences yes) custom: shows repeat monthly every [1] days (!!!) and no end date.  I believe the previously chosen settings should be presented for possible correction, rather than having to start again.  And I had to 'unchoose' monthly to weekly and back to monthly to get it to offer me the ability to set [?] months

I believe that attempting to set up this series of events should show you all the above.  Thanks VM, and grovel grovel if these problems have been reported already and I failed to find them - I did try!

Reproducible: Always

Steps to Reproduce:
1.I hope I have covered this in details
2.
3.
Actual Results:  
I hope I have covered this in details

Expected Results:  
* Four events on 2008-Aug-31 2008-Nov-30 2009-Feb-28 2009-May-31
* Set up the custom repeat preview should be scrollable to check far off events
* Editing custom repeat should present previous choices for correction

I hope I have covered that in Expected Results

Workaround is just boring: set up four individual events (%=((

Thanks team!
Duplicate of Bug 386516?

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Duplicate of bug: 386516
(Reporter)

Comment 3

10 years ago
I certainly agree that my first point is indeed a duplicate of 386515 and my apologies for not finding it!  However, also:

* failure to show already chosen custom repeat settings when editing the
reoccurring event (bug?)

When you edit previous work you really would want to be offered your initial entries for correction.

* custom preview not scrollable to view long off repeats; only three months on display (not a bug: facility limitation)

Not essential, but it would be nice.
You need to log in before you can comment on or make changes to this bug.