Closed Bug 452723 Opened 11 years ago Closed 10 years ago

Fennec app icon in Maemo N800/N810 task navigator

Categories

(Firefox for Android Graveyard :: General, defect, P3)

ARM
Maemo
defect

Tracking

(fennec1.0+)

VERIFIED FIXED
Tracking Status
fennec 1.0+ ---

People

(Reporter: tonikitoo, Assigned: bcombee)

References

Details

Attachments

(1 file)

Fennec logo (26x26 , probably) should appear in task navigator after launching fennec from main menu...
Flags: wanted-fennec1.0+
Priority: -- → P3
Target Milestone: --- → Fennec A3
Duplicate of this bug: 484254
Hardware: Other → ARM
Target Milestone: Fennec A3 → ---
Duplicate of this bug: 509551
tracking-fennec: --- → ?
Duplicate of this bug: 512324
from Ben Combee in bug 512324:

Looking on device, I see that we install 

/usr/share/icons/hicolor/scalable/hildon/fennec.png

but we don't also have a PNG in the /usr/share/icons/hicolor/26x26/hildon/
folder.  The apps that work on the device have icon files in both places.
tracking-fennec: ? → 1.0+
I looked at the window class name that's published by Fennec.  xprop reports that the WM_CLASS values of the Fennec window are "Navigator", "Fennec".

We put out two WM_CLASS strings on X - "Navigator" and "Fennec".  I tried setting a StartupWMClass option in fennec.desktop to both values, but I didn't see the icon with either.

However, I also modified the osso-xterm.desktop file to use the Fennec icon, and that did work, so I don't think the problem is a bad set of PNG files.  I think it's a combination of a desktop file that's not quite right and a main window that can't be read by the desktop manager.
Summary: Fennec logo in task navigator → Fennec app icon in Maemo N800/N810 task navigator
Whoa... just got the icon to display -- I moved around some lines in the desktop file to put with StartupWMClass line earlier and also used "Navigator" as the string.  I'll provide a patch soon.
Assignee: nobody → combee
Status: NEW → ASSIGNED
Attachment #400122 - Flags: review?(bugmail)
Attachment #400122 - Flags: review?(bugmail) → review+
pushed:
https://hg.mozilla.org/mobile-browser/rev/0cab7b6b3304
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
verified FIXED On build:

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20090914
Fennec/1.0b4pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.