"You must select a rating" error when adding a review but no HTML form field for rating

VERIFIED INVALID

Status

addons.mozilla.org Graveyard
Public Pages
--
critical
VERIFIED INVALID
10 years ago
2 years ago

People

(Reporter: beroal, Unassigned)

Tracking

({regression})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; uk-UA; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; uk-UA; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

Can't add a review because of mentioned error.

Reproducible: Always

Steps to Reproduce:
1. Go to the https://addons.mozilla.org/uk/firefox/reviews/add/991
2. Fill the form (there is no HTML form field for rating).
3. Click "Submit".
Actual Results:  
"You must select a rating." message in red.

Expected Results:  
Review is added.
Confirming; choosing a star rating and then clicking "Submit" on https://addons.mozilla.org/en-US/firefox/addon/1484 yields the same error :-)

I'll be sure to have this worked into my Selenium test suite.  (It has already caught bug 452739.)
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Hardware: PC → All

Comment 3

10 years ago
Is that only broken in production? I cannot reproduce, neither on preview nor on my dev copy.

Comment 4

10 years ago
Actually, this works as expected: You need to click on one of the stars to select how much you like/dislike the add-on. I'll add a screenshot for you in a few seconds.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 5

10 years ago
Created attachment 336083 [details]
Pick one of these five stars

Screenshot of the star ratings.
Verified invalid; the bug I _thought_ I saw is that we require a comment when submitting a review, even in the simple review form.  That's actually not a bug, though...
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

10 years ago
I'm sorry, I didn't see stars because I browse web with pictures turned off!
There are no Firefox's boxes (which usually mean pictures) in place of stars.
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.