Preferences: timezone is empty, and no selections possible

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: alfredo4570, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.16) Gecko/20080715 Ubuntu/7.10 (gutsy) Firefox/2.0.0.16
Build Identifier: Ligntning 0.9pre build 2008082818

Summary says it all.  See also a screenshot: http://alfredo4570.customer.netspace.net.au/var/select_the_closest_city_in_your_timezone.png 


Reproducible: Always

Steps to Reproduce:
1.Upgraded Lightning from 0.8 to 0.9pre to fix toolbar location bug.
2.Open Edit / Preferences / Lightning / Timezone
3.Timezone is empty
Actual Results:  
Timezone drop-down menu is empty

Expected Results:  
Some timezones should be visible.

Please refer to a screenshot http://alfredo4570.customer.netspace.net.au/var/select_the_closest_city_in_your_timezone.png for more info.

Comment 1

10 years ago
WFM. Anything errors in your js console?
Please check if Tools -> Error Console reports any error messages after opening the preference dialog. If yes please copy+paste them here.

Comment 3

10 years ago
Are you using a 3rd party Thunderbird theme or a 3rd party theme for the Ubuntu desktop? If yes, can you please try to revert back to the default theme and see if the bug persists?
(Reporter)

Comment 4

10 years ago
Reply to #1: (What's "WFM"?) Lots: I cannot cut and paste them as a group (unless there is a text file somewhere), so I will cut and paste them one at a time...

Error: Components.classes['@mozilla.org/calendar/datetime;1'] has no properties
Source File: chrome://calendar/content/calUtils.js
Line: 59

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67"  data: no]
Source File: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 67
Error: uncaught exception: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: getTimezoneService :: line 163"  data: no]

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67"  data: no]
Source File: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 67

Error: uncaught exception: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: getTimezoneService :: line 163"  data: no]

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67"  data: no]
Source File: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 67

Error: uncaught exception: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: getTimezoneService :: line 163"  data: no]

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67"  data: no]
Source File: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 67

Error: uncaught exception: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: getTimezoneService :: line 163"  data: no]

Error: this.mTreeView has no properties
Source File: chrome://calendar/content/calendar-task-tree.xml
Line: 850

Error: this.mTreeView has no properties
Source File: chrome://calendar/content/calendar-task-tree.xml
Line: 850

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67"  data: no]
Source File: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 67

Error: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: getCalendarManager :: line 145"  data: no]
Source File: chrome://calendar/content/calUtils.js
Line: 145

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67"  data: no]
Source File: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 67

Error: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://lightning/content/lightning-migration.xul :: checkOld :: line 62"  data: no]
Source File: chrome://lightning/content/lightning-migration.xul
Line: 62

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67"  data: no]
Source File: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 67

Error: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: getCalendarManager :: line 145"  data: no]
Source File: chrome://calendar/content/calUtils.js
Line: 145

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67"  data: no]
Source File: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 67

Error: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js -> file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calUtils.js :: getCalendarManager :: line 145"  data: no]
Source File: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js -> file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calUtils.js
Line: 145

Error: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js -> file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calUtils.js :: getCalendarManager :: line 145"  data: no]
Source File: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js -> file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calUtils.js
Line: 145

Error: calendar has no properties
Source File: chrome://calendar/content/calendar-task-editing.js
Line: 107

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67"  data: no]
Source File: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 67

Error: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: getTimezoneService :: line 163"  data: no]
Source File: chrome://calendar/content/calUtils.js
Line: 163

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67"  data: no]
Source File: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 67

Error: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: getDateFormatter :: line 200"  data: no]
Source File: chrome://calendar/content/calUtils.js
Line: 200
________________________________________________________________________________

Reply to #2: Yes, one new error:

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67"  data: no]
Source File: file:///home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 67
________________________________________________________________________________

Reply to #3: No Ubuntu theme, no Thunderbird theme.

Comment 5

10 years ago
WFM == works for me

Does your system meet the requirement, especially libstc++ ?

<http://www.mozilla.org/projects/calendar/lightning/system-requirements.html>
(Reporter)

Comment 6

10 years ago
Reply to #5: System is Ubuntu 7.10 with all updates and GCC 4.1.

From http://www.mozilla.org/projects/calendar/lightning/system-requirements.html

Software Requirements
* Linux kernel - 2.2.14 or higher --- "uname -a" gives "Linux krustowski 2.6.22-15-generic #1 SMP Wed Aug 20 18:39:13 UTC 2008 i686 GNU/Linux"

  o glibc 2.3.2 or higher --- can't see on Synaptic Package Manager: how do I get this? (as part of GCC it's GCC 4.1)
  o XFree86-3.3.6 or higher --- can't see this either
  o gtk+2.0 or higher --- Synaptic Package Manager says 1:2.12.2-0ubuntu1
  o fontconfig (also known as xft) --- 2.4.2-1.2ubuntu4(gutsy)
  o libstdc++5 --- yes, both 5 & 6 installed: 5 is 1:3.3.6-15ubuntu2(gutsy), 6 is 4.2.1-5ubuntu4(gutsy)
    (Many modern Linux distributions only package libstdc++6, which is incompatible with Lightning. Therefore please install the package "libstdc++5" or "compat-libstdc++" on your system before installing Lightning)


Minimum Hardware
* Intel Pentium II or AMD K6-III+ 233 MHz CPU (Recommended: 500MHz or greater) --- 1.4 GHz Intel
* 64 MB RAM (Recommended: 128 MB RAM or greater) --- 512 Mb
* 52 MB hard drive space --- yes, Gigs

Comment 7

10 years ago
Have your system had libstdc++.5 installed before you've installed lightning?
Since the calendar core components cannot be loaded, could you please check libcalbasecomps.so in your profile's directory, e.g. ldd -r libcalbasecomps.so? I suspect there are missing dependent libraries.
(Reporter)

Comment 8

10 years ago
Reply to #7: System was built 2nd August from CD.
"Have your system had libstdc++.5 installed before you've installed lightning?"
Probably?  I don't recall explicitly installing it.


Checking libcalbasecomps.so :
$ slocate libcalbasecomps.so
/home/homer/.mozilla-thunderbird/kjh3vn9o.homer/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libcalbasecomps.so

$ ldd -r libcalbasecomps.so 
        linux-gate.so.1 =>  (0xffffe000)
        libxpcom.so => not found
        libxpcom_core.so => not found
        libplds4.so => not found
        libplc4.so => not found
        libnspr4.so => not found
        libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7f46000)
        libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7f42000)
        libmozjs.so => not found
        libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0xb7e87000)
        libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7e62000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7e57000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7d0d000)
        /lib/ld-linux.so.2 (0x80000000)
undefined symbol: PL_DHashAllocTable    (./libcalbasecomps.so)
undefined symbol: PL_DHashFreeTable     (./libcalbasecomps.so)
undefined symbol: PL_DHashMoveEntryStub (./libcalbasecomps.so)
undefined symbol: PL_DHashFinalizeStub  (./libcalbasecomps.so)
undefined symbol: _ZN12nsCharTraitsIcE12sEmptyBufferE   (./libcalbasecomps.so)
undefined symbol: PR_GMTParameters      (./libcalbasecomps.so)
undefined symbol: _ZN12nsCharTraitsItE12sEmptyBufferE   (./libcalbasecomps.so)
undefined symbol: _ZTV28nsCreateInstanceByContractID    (./libcalbasecomps.so)
undefined symbol: _ZN18nsObsoleteACString16sCanonicalVTableE    (./libcalbasecomps.so)
undefined symbol: _ZN17nsObsoleteAString16sCanonicalVTableE     (./libcalbasecomps.so)
undefined symbol: _ZN20nsPromiseFlatCString4InitERK19nsACString_internal        (./libcalbasecomps.so)
undefined symbol: NS_Free_P     (./libcalbasecomps.so)
undefined symbol: _ZNK12nsCSubstring6EqualsERK19nsACString_internal     (./libcalbasecomps.so)
undefined symbol: PR_ImplodeTime        (./libcalbasecomps.so)
undefined symbol: _ZN13nsCOMPtr_base18assign_with_AddRefEP11nsISupports (./libcalbasecomps.so)
undefined symbol: PL_DHashTableOperate  (./libcalbasecomps.so)
undefined symbol: _ZN18nsAString_internalD2Ev   (./libcalbasecomps.so)
undefined symbol: _ZN19nsACString_internal6AssignEPKcj  (./libcalbasecomps.so)
undefined symbol: _ZN11nsVoidArrayC1Ev  (./libcalbasecomps.so)
undefined symbol: _ZN11nsSubstring7ReplaceEjjPKtj       (./libcalbasecomps.so)
undefined symbol: _ZN19nsACString_internal11AssignASCIIEPKcj    (./libcalbasecomps.so)
undefined symbol: _ZN15nsCOMArray_base14InsertObjectAtEP11nsISupportsi  (./libcalbasecomps.so)
undefined symbol: _ZNK14nsCStringArray9CStringAtEiR19nsACString_internal        (./libcalbasecomps.so)
undefined symbol: PL_DHashTableInit     (./libcalbasecomps.so)
undefined symbol: JS_DefineUCProperty   (./libcalbasecomps.so)
undefined symbol: _ZNK19nsACString_internal11EqualsASCIIEPKcj   (./libcalbasecomps.so)
undefined symbol: js_NewDateObject      (./libcalbasecomps.so)
undefined symbol: JS_GetStringLength    (./libcalbasecomps.so)
undefined symbol: _ZN12nsCSubstring6AssignERKS_ (./libcalbasecomps.so)
undefined symbol: _ZN8nsMemory5CloneEPKvj       (./libcalbasecomps.so)
undefined symbol: _Z10HashStringRK19nsACString_internal (./libcalbasecomps.so)
undefined symbol: _ZN19nsACString_internal6AssignERKS_  (./libcalbasecomps.so)
undefined symbol: NS_Alloc_P    (./libcalbasecomps.so)
undefined symbol: _ZNK19nsACString_internal6IsVoidEv    (./libcalbasecomps.so)
undefined symbol: js_NewDateObjectMsec  (./libcalbasecomps.so)
undefined symbol: _ZN19nsACString_internal6AssignEPKc   (./libcalbasecomps.so)
undefined symbol: _ZN15nsCOMArray_base5ClearEv  (./libcalbasecomps.so)
undefined symbol: _ZN11nsSubstring6AssignERKS_  (./libcalbasecomps.so)
undefined symbol: _ZN13nsCOMPtr_base25assign_from_gs_contractidE24nsGetServiceByContractIDRK4nsID       (./libcalbasecomps.so)
undefined symbol: JS_GetStringChars     (./libcalbasecomps.so)
undefined symbol: _ZN11nsVoidArray4SortEPFiPKvS1_PvES2_ (./libcalbasecomps.so)
undefined symbol: js_DateIsValid        (./libcalbasecomps.so)
undefined symbol: _ZN13nsCOMPtr_baseD2Ev        (./libcalbasecomps.so)
undefined symbol: _Z20NS_NewGenericModule2PK12nsModuleInfoPP9nsIModule  (./libcalbasecomps.so)
undefined symbol: PL_DHashTableFinish   (./libcalbasecomps.so)
undefined symbol: _ZN13nsCOMPtr_base18assign_from_helperERK15nsCOMPtr_helperRK4nsID     (./libcalbasecomps.so)
undefined symbol: PL_DHashTableEnumerate        (./libcalbasecomps.so)
undefined symbol: _ZNK12nsCSubstring11EqualsASCIIEPKcj  (./libcalbasecomps.so)
undefined symbol: _ZN15nsCOMArray_baseD2Ev      (./libcalbasecomps.so)
undefined symbol: PR_snprintf   (./libcalbasecomps.so)
undefined symbol: _ZN12nsCSubstring6AssignERK19nsACString_internal      (./libcalbasecomps.so)
undefined symbol: _Z17AppendUTF8toUTF16PKcR18nsAString_internal (./libcalbasecomps.so)
undefined symbol: _ZNK19nsACString_internal6EqualsEPKc  (./libcalbasecomps.so)
undefined symbol: _ZNK11nsSubstring11EqualsASCIIEPKcj   (./libcalbasecomps.so)
undefined symbol: PR_ExplodeTime        (./libcalbasecomps.so)
undefined symbol: _ZN19nsACString_internal9SetLengthEj  (./libcalbasecomps.so)
undefined symbol: js_DateGetMsecSinceEpoch      (./libcalbasecomps.so)
undefined symbol: _ZNK19nsACString_internal6LengthEv    (./libcalbasecomps.so)
undefined symbol: _ZN13nsCOMPtr_base16begin_assignmentEv        (./libcalbasecomps.so)
undefined symbol: _ZN18nsAString_internal9SetIsVoidEi   (./libcalbasecomps.so)
undefined symbol: _ZN19nsACString_internal9SetIsVoidEi  (./libcalbasecomps.so)
undefined symbol: _ZN19nsACString_internalD2Ev  (./libcalbasecomps.so)

Comment 9

10 years ago
(In reply to comment #8)
>         libxpcom.so => not found
>         libxpcom_core.so => not found
>         libplds4.so => not found
>         libplc4.so => not found
>         libnspr4.so => not found
Please make sure you have thunderbird's libs in your LD_LIBRARY_PATH (or similar so that ld finds them) before running ldd.
(Reporter)

Comment 10

10 years ago
Reply to #9: (1) What needs to be done to the installer(s) for T-bird and/or Lightning, so that these are found on installation?  (2) How are they added to the dependencies?

There's no LD_LIBRARY_PATH in set or env:
$ env | grep LD_LIBRARY_PATH
$ set | grep LD_LIBRARY_PATH
$ 

(3) Which path should I set LD_LIBRARY_PATH to?  Because there's *multiple* copies of *all* of these on the system:

$ slocate libxpcom.so
/usr/lib/libxpcom.so.0d
/usr/lib/firefox/libxpcom.so
/usr/lib/xulrunner/libxpcom.so
/usr/lib/thunderbird/libxpcom.so
$ slocate libxpcom_core.so
/usr/lib/firefox/libxpcom_core.so
/usr/lib/thunderbird/libxpcom_core.so
$ slocate libplds4.so
/usr/lib/firefox/libplds4.so
/usr/lib/xulrunner/libplds4.so
/usr/lib/libplds4.so.0d
/usr/lib/thunderbird/libplds4.so
$ slocate libplc4.so
/usr/lib/firefox/libplc4.so
/usr/lib/xulrunner/libplc4.so
/usr/lib/libplc4.so.0d
/usr/lib/thunderbird/libplc4.so
$ slocate libnspr4.so
/usr/lib/libnspr4.so.0d
/usr/lib/firefox/libnspr4.so
/usr/lib/xulrunner/libnspr4.so
/usr/lib/thunderbird/libnspr4.so
$
(Reporter)

Comment 11

10 years ago
Sorry, most of these are links:

$ slocate libxpcom.so | xargs ls -l 
-rw-r--r-- 1 root root 10052 2008-07-16 03:58 /usr/lib/firefox/libxpcom.so
-rw-r--r-- 1 root root  9992 2007-09-30 11:26 /usr/lib/libxpcom.so.0d
-rw-r--r-- 1 root root 10052 2008-07-25 01:53 /usr/lib/thunderbird/libxpcom.so
lrwxrwxrwx 1 root root    17 2008-08-06 11:29 /usr/lib/xulrunner/libxpcom.so -> ../libxpcom.so.0d
$ slocate libxpcom_core.so | xargs ls -l 
-rw-r--r-- 1 root root 692544 2008-07-16 03:58 /usr/lib/firefox/libxpcom_core.so
-rw-r--r-- 1 root root 692576 2008-07-25 01:53 /usr/lib/thunderbird/libxpcom_core.so
$ slocate libplds4.so | xargs ls -l 
lrwxrwxrwx 1 root root   17 2008-08-03 02:15 /usr/lib/firefox/libplds4.so -> ../libplds4.so.0d
-rw-r--r-- 1 root root 8232 2007-05-03 05:58 /usr/lib/libplds4.so.0d
lrwxrwxrwx 1 root root   17 2008-08-02 19:41 /usr/lib/thunderbird/libplds4.so -> ../libplds4.so.0d
lrwxrwxrwx 1 root root   17 2008-08-06 11:29 /usr/lib/xulrunner/libplds4.so -> ../libplds4.so.0d
$ slocate libplc4.so | xargs ls -l 
lrwxrwxrwx 1 root root    16 2008-08-03 02:15 /usr/lib/firefox/libplc4.so -> ../libplc4.so.0d
-rw-r--r-- 1 root root 14332 2007-05-03 05:58 /usr/lib/libplc4.so.0d
lrwxrwxrwx 1 root root    16 2008-08-02 19:41 /usr/lib/thunderbird/libplc4.so -> ../libplc4.so.0d
lrwxrwxrwx 1 root root    16 2008-08-06 11:29 /usr/lib/xulrunner/libplc4.so -> ../libplc4.so.0d
$ slocate libnspr4.so | xargs ls -l 
lrwxrwxrwx 1 root root     17 2008-08-03 02:15 /usr/lib/firefox/libnspr4.so -> ../libnspr4.so.0d
-rw-r--r-- 1 root root 193772 2007-05-03 05:58 /usr/lib/libnspr4.so.0d
lrwxrwxrwx 1 root root     17 2008-08-02 19:41 /usr/lib/thunderbird/libnspr4.so -> ../libnspr4.so.0d
lrwxrwxrwx 1 root root     17 2008-08-06 11:29 /usr/lib/xulrunner/libnspr4.so -> ../libnspr4.so.0d
$ 

(4) Worrying, perhaps, that there are two versions of libxpcom.so & libxpcom_core.so.

(5) What should I set LD_LIBRARY_PATH to?  Is this OK?
LD_LIBRARY_PATH=/usr/lib/firefox/;/usr/lib/thunderbird/

(6) Where should I put this?   In /etc/profile?  (which is for bash?)  Or /etc/thunderbird/profile/prefs.js ?

Comment 12

10 years ago
(In reply to comment #8)
> Reply to #7: System was built 2nd August from CD.
> "Have your system had libstdc++.5 installed before you've installed lightning?"
> Probably?  I don't recall explicitly installing it.

Please install libstdc++.5 and re-install lightning after that.
(Reporter)

Comment 13

10 years ago
Reply to #8: (Sorry, re-reading my response, I can see that it could be taken either of two ways.)

"Have your system had libstdc++.5 installed before you've installed lightning?"

Yes, it *is* installed, and 
*definitely* installed before Lightning 0.9pre, and
*probably* installed before Lightning 0.8.

"Please install libstdc++.5 and re-install lightning after that."

Since libstdc++5 was already installed, I uninstalled Lightning, exited T-bird, restarted T-bird, and....

.... the Timezones have reappeared .... Problem has disappeared: well done.

Is this just an unresolved dependency issue?
(Reporter)

Comment 14

10 years ago
*Reply to #12, not #8.

Comment 15

10 years ago
(In reply to comment #13)

> Since libstdc++5 was already installed, I uninstalled Lightning, exited T-bird,
> restarted T-bird, and....
> 
> .... the Timezones have reappeared .... Problem has disappeared: well done.

I guess you meant to say you re-installed lightning after this? Why else would you see timezones? 

> 
> Is this just an unresolved dependency issue?

Yes, you first have to install libstdc5++ and then install lightning.
Setting to WFM per comment 13.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 17

10 years ago
Reply to #15:
> Is this just an unresolved dependency issue?
What I *meant* by this (natural language is hard to use for specifications) is that:
Why doesn't the installation of Lightning also install libstdc++5? (Is this even possible?)
You need to log in before you can comment on or make changes to this bug.