Closed Bug 452794 Opened 16 years ago Closed 16 years ago

Can't minimize while logged in to facebook

Categories

(Core :: General, defect, P1)

x86
All
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: zurtex, Unassigned)

References

Details

(Keywords: regression, testcase)

Attachments

(1 file)

1. Visit www.facebook.com
2. sign-up / log in
3. Minimize the firefox window
4. The window re-appears

Expected result:
Firefox should stay minimised.

Tested on:
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1a2pre) Gecko/20080828034823 Minefield/3.1a2pre ID:20080828034823

Both in safemode and with a clean profile. I can not repeat bug for Firefox 3.0.1
WFM using build:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/20080829031319 Minefield/3.1a2pre Firefox/3.0 ID:20080829031319
I'm seeing this bug as well. When I try to minimize, it minimizes then re-appears as a tiny window in the top left of my screen then moves to the center of the screen. When I have multiple tabs, this only happens when the facebook tab is showing when I minimize. It happens on any facebook page I view, except on the logged-out page. 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080830031750 Minefield/3.1b1pre
OS: Windows Server 2003 → Windows XP
This is an incredibly annoying bug that will affect a great deal of users, now I have an independent confirmation I'm nominating for blocking.

Confirmed on XP and XP x64, also, I'm on the new version of facebook, what about other people?
Flags: blocking-firefox3.1?
I completely agree. 

This bug does not exist in the nightly from 08-14-2008 (20080814041610) but does exist in the nightly from 08-15-2008 (20080815064214) if that helps.
Well it means whatever caused the bug should be somewhere on this list:

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-08-14+04%3A16%3A10&enddate=2008-08-15+06%3A42%3A14

I've asked around, but no particular bug seems a good candidate, and no hourly archive exists so I can't narrow it down any further. After some time I did figure out it wasn't pushed on to the tracemonkey builds until this this window:

http://hg.mozilla.org/tracemonkey/pushloghtml?startdate=2008-08-20+07%3A14%3A48&enddate=2008-08-22+03%3A31%3A55

But that's a big list so not very useful.
Keywords: regression
Martijn helped me come up with a reduced test case for this issue (attached).  It looks like this might have been regressed by the fix in bug 422792
Depends on: 422792
Flags: blocking-firefox3.1?
Keywords: testcase
Product: Firefox → Core
QA Contact: general → general
Flags: blocking1.9.1?
Blocks: 422792
No longer depends on: 422792
Notice with the testcase you can't maximize from a non maximized window either. This bug might want a more appropriate naming, but I'm not sure what.

Thanks a lot for the work, I suspected that was the offending bug.
That test case is spot-on. I tried backing out that changeset (c7264525ad20) and rebuilding, but the bug still persisted.
Backing out the patch from bug 449885 and bug 443878 didn't help either. Perhaps a regression from bug 418454, somehow then?
No longer blocks: 422792
I suspect bug 448132 might be to blame, but I don't have time to confirm it.
Ah, yes, backing out the patch for bug 448132 fixes the bug.
(it really sucks that the hg blame view doesn't show the list of affected files as bonsai blame did)
Blocks: 448132
I gather this is an XP bug only, as I cannot repo this at all using Vista HP SP1

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080909043009 Minefield/3.1b1pre Firefox/3.0 ID:20080909043009
It's also a Windows Sever 2003 bug
(In reply to comment #12)
> I gather this is an XP bug only, as I cannot repo this at all using Vista HP
> SP1
> 
> Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre)
> Gecko/20080909043009 Minefield/3.1b1pre Firefox/3.0 ID:20080909043009

I verified this bug on Vista as well. Not sure why logging into facebook has any effect on why the window won't minimize properly.
OS: Windows XP → All
Facebook no longer causes this (I assume they fixed their code). But the testcase seems to be worse, you can no longer re-size the window anymore.
Since this isn't affecting Facebook any longer, I don't think we should block, but we should get this on the list of top wanted bugs, even after 1.9.1.  Marking as such.
Flags: wanted1.9.1+
Flags: blocking1.9.1?
Flags: blocking1.9.1-
Priority: -- → P1
I believe the patch for bug 454473 fixed this. I'd like someone else to confirm on XP (I've verified on Vista) not that there should be any difference.
(In reply to comment #17)
> I believe the patch for bug 454473 fixed this. I'd like someone else to confirm
> on XP (I've verified on Vista) not that there should be any difference.

Yup, the test case now Works for me on XP x64
Fixed by bug 454473.
Status: NEW → RESOLVED
Closed: 16 years ago
Depends on: 454473
Resolution: --- → FIXED
You can no longer maximise on this test case. Is this correct behavior or does a new bug need filing?
That's correct behavior.
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: