Closed Bug 452832 Opened 16 years ago Closed 16 years ago

drag and drop multiple messages between folders fails (moves only one)

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird 3.0a3

People

(Reporter: wsmwk, Assigned: enndeakin)

References

Details

(Keywords: regression)

Attachments

(1 file)

drag and drop multiple messages between folders fails. 
single message works.
trunk regression
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/20080828032200 Shredder/3.0b1pre
Flags: blocking-thunderbird3.0b1?
Severity: normal → major
Problem was reproduced with trunk 2008/8/25 build on MS Win-XP SP3.
After restart of Tb, following error was observed at Error Console. 
> Error: redeclaration of const kNonStringDataLength
> Source File: chrome://global/content/nsDragAndDrop.js Line: 4
Yes, this should block beta, it is pretty normal functionality.
Flags: blocking-thunderbird3.0b1? → blocking-thunderbird3.0b1+
Keywords: regression
Target Milestone: --- → Thunderbird 3.0b1
BTW, this probably also happens on SeaMonkey, so this might be in shared code.
(Worksforme)
> [App] Name=Thunderbird Version=3.0b1pre BuildID=20080824031147
(Confirmed)
> [App] Name=Thunderbird Version=3.0b1pre BuildID=20080825031404

> Check-in's between 2008-08-24 00:00:00 and 2008-08-25 06:00:00
> http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-08-24+00%3A00%3A00&maxdate=2008-08-25+06%3A00%3A00&cvsroot=%2Fcvsroot
Summary: drag and drop multiple messages between folders fails → drag and drop multiple messages between folders fails (moves only one)
Bonsai tracks the CVS trunk, which is the 3.0.x stream; nightlies for trunk are coming off of hg.  So the checkins from hg are:

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-08-24+00%3A00%3A00&enddate=2008-08-25+06%3A00%3A00

and

http://hg.mozilla.org/comm-central/pushloghtml?startdate=2008-08-24+00%3A00%3A00&enddate=2008-08-25+06%3A00%3A00

Looks like a regression from bug 356295; adding Neil Deakin to the CC.
It was clear from the beginning that bug 356295 is the cause, it broke when it was first in, worked again when it was backed out, broke again when it re-landed. That's why the dependency was set here all the time, I don't know why someone bothered to look into a regressions range or such at all when we knew that all along.
Probably the new drag-and-drop stuff needs some more fixes on our (mailnews) side to deal with some new way of specifying d&d of multiple messages, I thought that was clear from the start?

BTW, same error console message as in comment #1 is also seen in SeaMonkey.
(In reply to comment #0)
> drag and drop multiple messages between folders fails. 

Fails in what way?
(In reply to comment #9)
> (In reply to comment #0)
> > drag and drop multiple messages between folders fails. 
> 
> Fails in what way?

Ref. the revised summary : only one message is moved.
It looks like the wrong version of messengerdnd.js was reviewed and checked in.

Rather than:

  dataTransfer.mozSetDataAt(flavor, selArray);

It should have code that iterates over the array and adds each item separately, something like the following:

var count = selArray.length;
for (var i = 0; i < count; ++i )
  dataTransfer.mozSetDataAt(flavor, selArray[i], i);
(In reply to comment #1)
> > Error: redeclaration of const kNonStringDataLength
> > Source File: chrome://global/content/nsDragAndDrop.js Line: 4

I filed bug 453220 ;-)
Attached patch untested patchSplinter Review
It would be good if someone tested this to see if it works.
Bah~, so I was hitting this the past few days as well... :|
OS: Windows Vista → All
Hardware: PC → All
(In reply to comment #13)
> It would be good if someone tested this to see if it works.

Thanks, this patch indeed seems to work - at least in my Linux SeaMonkey build :)
Attachment #336494 - Flags: review?(bienvenu)
Whiteboard: [needs review bienvenu]
Attachment #336494 - Flags: superreview+
Attachment #336494 - Flags: review?(bienvenu)
Attachment #336494 - Flags: review+
Comment on attachment 336494 [details] [diff] [review]
untested patch

thx, Neil, works for Thunderbird as well, r/sr=me. I've landed this, changeset:   260:b5886f652382
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Assignee: nobody → enndeakin
verified fixed
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
This FIXED bug is flagged with in‑testsuite?   It would be great if assignee or someone else can clear the flag if a test is not appropriate.  And if appropriate, create a test and plus the flag to finish off the bug.
Whiteboard: [needs review bienvenu]
actually, this would be much more appropriate for a litmus test. I doubt we can do drag drop that well with mozmill.
Flags: in-testsuite?
Flags: in-testsuite-
Flags: in-litmus?
Flags: in-litmus? → in-litmus+
Reproduced on Windows XP, TB 3.0.4. [Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4]

Maybe not related, but when I move a folder to another one, I get the following console error:
--
Erreur : uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIRDFService.GetResource]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Thunderbird/modules/MailUtils.js :: MailUtils_getFolderForURI :: line 118"  data: no]
--

Recent regression?
Reproduced with TB 3.1rc2 (Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.4) Gecko/20100608 Lightning/1.0b1 Thunderbird/3.1).

Now I no longer have the console error.
Looks like the bug has been re-introduced with TB 9 and is still present in TB 10.0.1 [Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.8.1.24) Gecko/20100228 Thunderbird/2.0.0.24 Mnenhy/0.7.5.0] in conjunction with IMAP boxes (tested with different servers). Folder compaction is active in TB. The only active add-on is Test Pilot. Can anyone confirm this behaviour?
(In reply to Christian Winter from comment #25)
> Looks like the bug has been re-introduced with TB 9 and is still present in
> TB 10.0.1 [Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.8.1.24)
> Gecko/20100228 Thunderbird/2.0.0.24 Mnenhy/0.7.5.0] in conjunction with IMAP
> boxes (tested with different servers). Folder compaction is active in TB.
> The only active add-on is Test Pilot. Can anyone confirm this behaviour?

Please don't comment on fixed bugs - your comments are likely to get lost. If you need support please use our support site: http://getsatisfaction.com/mozilla_messaging/ - if you have a bug, please file a new bug.

Also, your user agent is incorrect for TB 10.0.1 and may cause you some minor issues, see https://support.mozillamessaging.com/en-US/kb/build-number-not-displayed for how to fix it.
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: