Closed Bug 452850 Opened 11 years ago Closed 11 years ago

OSX mozilla-central nightly seems to be out of disk space

Categories

(Release Engineering :: General, defect, P2, major)

x86
macOS

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mossop, Assigned: nthomas)

References

()

Details

Build failed with:

/builds/moz2_debug_slave/mozilla-central-macosx-nightly/build/build/macosx/universal/unify \
	  obj-firefox/ppc/dist/firefox/Minefield.app \
	  obj-firefox/i386/dist/firefox/Minefield.app \
	  obj-firefox/ppc/dist/universal/firefox/Minefield.app
lipo: can't write to output file: obj-firefox/ppc/dist/universal/firefox/Minefield.app/Contents/MacOS/XUL (No space left on device)
/builds/moz2_debug_slave/mozilla-central-macosx-nightly/build/build/macosx/universal/unify: lipo create fat failed for:
  obj-firefox/ppc/dist/firefox/Minefield.app/Contents/MacOS/XUL,
  obj-firefox/i386/dist/firefox/Minefield.app/Contents/MacOS/XUL,
  obj-firefox/ppc/dist/universal/firefox/Minefield.app/Contents/MacOS/XUL
make[1]: *** [postflight_all] Error 1
make: *** [build] Error 2
program finished with exit code 2
Assignee: server-ops → nobody
Component: Server Operations → Release Engineering: Maintenance
QA Contact: mrz → release
In particular bm-xserve19 but still investigating.
Assignee: nobody → nthomas
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P2
Ok, I deleted a failed nightly build on bm-xserve19, so it should be able to succeed now. Forced a build.

I think this was also causing redness on the debug build, as bm-xserve17 and 19 were both getting given jobs - 19 would fail to upload logs properly, then 17 wouldn't be able to work out the change since the last run.
Builds are green.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Component: Release Engineering: Maintenance → Release Engineering
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.