Clone should also preserve "Blocks" and "Depends on" fields

RESOLVED FIXED in Bugzilla 3.4

Status

()

--
enhancement
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: alqahira, Assigned: nbezzala)

Tracking

Bugzilla 3.4
Bug Flags:
approval +

Details

Attachments

(1 attachment, 2 obsolete attachments)

STR:

1. Visit bug 452906 (which currently is set to block bug 452731)
2. Clone bug (in this case, even into the same product/component)

AR: Observe that the "Blocks" field is empty

ER: "Blocks" field should be populated with "452731" as in the source bug 452906.

Of the fields that are non-unique and available on the Enter Bug page (e.g., "Alias" is unique, and "Status Whiteboard" is not available on the Enter Bug page), only "Blocks" and "Depends" are not cloned.  

If I'm cloning a bug that blocks or depends on another bug, it's quite likely that the new cloned bug will also block or depend on the same bug as the source bug.  Instead, I have to manually (re)populate these fields.

Comment 1

10 years ago
This behavior is currently intentional, i.e. it's not a bug. Currently, the single bug added to the dependson field is the bug being cloned.
Severity: normal → enhancement

Comment 2

10 years ago
I think Smokey's argument makes sense, though, and I doubt it would be that hard to implement.
Summary: Clone fails to preserve "Blocks" and "Depends on" fields → Clone should also preserve "Blocks" and "Depends on" fields
Whiteboard: [Good Intro Bug]
Target Milestone: --- → Bugzilla 4.0

Comment 3

10 years ago
(In reply to comment #2)
> I think Smokey's argument makes sense, though

Oh, I'm not saying it doesn't. I'm only saying it's not a bug but an enhancement request (which indeed makes sense).
(Assignee)

Comment 4

10 years ago
Created attachment 354588 [details] [diff] [review]
clone preserves blocks and depends on

Displaying a comma separated list of depends on and blocked bugs.
(Assignee)

Updated

10 years ago
Attachment #354588 - Flags: review?(mkanat)

Comment 5

10 years ago
it depends on what you're doing.

half the time you're probably trying to make a clone of a series of bugs, in which case this is absolutely the wrong thing to do

Updated

10 years ago
Attachment #354588 - Flags: review?(mkanat) → review-

Comment 6

10 years ago
Comment on attachment 354588 [details] [diff] [review]
clone preserves blocks and depends on

You should also include the original bug id in the dependson list.
(Assignee)

Comment 7

10 years ago
Created attachment 354654 [details] [diff] [review]
Added original bug to dependson list

I just added the original bug to the beginning of the depends on list. 
Should I sort the list after adding it?
Attachment #354588 - Attachment is obsolete: true
Attachment #354654 - Flags: review?(mkanat)

Comment 8

10 years ago
Comment on attachment 354654 [details] [diff] [review]
Added original bug to dependson list

No, sorting the list is unnecessary, but you're adding a comma even when it's not needed, which is going to look weird to people. Just add $cloned_bug_id as another argument to join() (but make sure it still comes first in the list).
Attachment #354654 - Flags: review?(mkanat) → review-
(Assignee)

Comment 9

10 years ago
Created attachment 354783 [details] [diff] [review]
Clone should also preserve "Blocks" and "Depends on" fields
Attachment #354654 - Attachment is obsolete: true
Attachment #354783 - Flags: review?(mkanat)

Comment 10

10 years ago
Comment on attachment 354783 [details] [diff] [review]
Clone should also preserve "Blocks" and "Depends on" fields

Yeah, this looks good to me.
Attachment #354783 - Flags: review?(mkanat) → review+

Updated

10 years ago
Flags: approval+
Keywords: relnote

Updated

10 years ago
Assignee: create-and-change → nbezzala
Status: NEW → ASSIGNED
Whiteboard: [Good Intro Bug]
Target Milestone: Bugzilla 4.0 → Bugzilla 3.4

Comment 11

10 years ago
Checking in enter_bug.cgi;
/cvsroot/mozilla/webtools/bugzilla/enter_bug.cgi,v  <--  enter_bug.cgi
new revision: 1.166; previous revision: 1.165
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 12

9 years ago
Added to the release notes for Bugzilla 3.4 in bug 494037.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.