inconsistent visual/logical cursor moving with ths arrows, in rtl input field with ltr text, or, ltr iput field with rtl text

RESOLVED DUPLICATE of bug 167288

Status

()

--
minor
RESOLVED DUPLICATE of bug 167288
10 years ago
10 years ago

People

(Reporter: beseg7, Unassigned)

Tracking

({rtl})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; he; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; he; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Look at the linked URL. 

In the first input there is RTL direction and RTL text. When placing the cursor in middle of the text, and moving right/left, it's moving to the correct place logically & visually.

The seond input is good as well, with LTR direction and LTR text.


The 3rd and 4th are messed up.

When placing the cursor in the middle of them and moving right/left, it is moving VISUALLY right/left, and not LOGICALLY (according to the direction). It's bad, but it's not all.

When holding SHIFT pressed for selecting the text, and then using right/left arrows, the behavior become to LOGICALLY and not VISUALLY. Leave the SHIFT, oops - VISUALLY again. :)


Reproducible: Always

Steps to Reproduce:
1. Put character with LTR directionality in input field with RTL directionality, or RTL in LTR.
2. Try moving with arrows among the text.
3. Hold SHIFT key.
4. Try moving with arrows among the text.

Actual Results:  
Without SHIFT - it moves VISUALLY;
with SHIFT - it moves LOGICALLY.

Expected Results:  
It sholud allways move LOGICALLY (like in FF2).

Updated

10 years ago
Component: General → Editor
Keywords: rtl
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → editor
Hardware: PC → All
This change was introduced in bug 330175. You can restore the previous behaviour by setting bidi.edit.caret_movement_style to 1 in about:config and restarting the browser.
(Reporter)

Comment 2

10 years ago
Okay. Actually, "0" is the correct value for LOGICALLY behaviour ("1" is good for always VISUALLY).

However, I can't see any reason to use "2"... it's very strange behavior (you start to move to one direction for selecting word, then you adding the SHIFT key, and *boom*, you are moving to the other direction...).
More than that; people used to the LOGICALLY behavior (this is standard, I think, in most of other software), so it's seems to be reasonable that the default will be "0".
See my last comment in bug 167288
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 167288
You need to log in before you can comment on or make changes to this bug.