Closed Bug 453050 Opened 11 years ago Closed 11 years ago

TM: Crash [@ TraceRecorder::getThis] with setter

Categories

(Core :: JavaScript Engine, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 452495

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, testcase)

Crash Data

js -j     
js> this.__defineSetter__('x', function(){});
js> for (var j = 0; j < 3; ++j) { for (x in this) { } }

Crash [@ TraceRecorder::getThis]
Summary: Crash [@ TraceRecorder::getThis] with setter → TM: Crash [@ TraceRecorder::getThis] with setter
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 452495
Crash Signature: [@ TraceRecorder::getThis]
A testcase for this bug was already added in the original bug (bug 452495).
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.