'Help' menu comprises instances of "b" and "Blank menu item"

VERIFIED WORKSFORME

Status

SeaMonkey
Help Documentation
P3
major
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: Eli Goldberg, Assigned: saari (gone))

Tracking

Trunk
Future
PowerPC
All

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

(Reporter)

Description

18 years ago
...on both the Commercial & Mozilla builds for Mac OS, each time you open a new 
window, the Help menu's items below "Show Balloons" comprise:

"b"
"Blank Menu Item"
"Blank Menu Item"
"Blank Menu Item"
-----------------
"Blank Menu Item"
"Blank Menu Item"
"Blank Menu Item"
-----------------
"Blank Menu Item"

After ~10 seconds on a 450 Mhz G4, the "real" menu item appears.
(Reporter)

Updated

18 years ago
Keywords: nsbeta2
OS: Mac System 8.5 → Mac System 9.0

Comment 1

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2. 
Whiteboard: [nsbeta2-]

Comment 2

18 years ago
Copying Ian... Ian, is this yours, or do you know who should own this? Thanks.
(Reporter)

Comment 3

18 years ago
Please note that:

* It can often take several minutes until the actual menu items appear. I'm not 
sure if a series of user actions are necessary to make it appear; if so, I can't 
identify them.

* Selecting the "b" menu item results in a nasty crash in the Bowels of the 
Memory Manager, which results in the entire Mac requiring a restart. (all other 
applications crash on launch thereafter.)

I'm removing nsbeta2- for reconsideration.
(Reporter)

Updated

18 years ago
Whiteboard: [nsbeta2-]
(Reporter)

Comment 4

18 years ago
...please note that the Mozilla build only includes two instances of "Blank menu 
item", and doesn't include the Nasty Crashing 'B'.

Comment 5

18 years ago
Adding crash keyword.  Putting on [nsbeta2+] radar for beta2 fix. The + is to 
only stop the crash. Who is going to fix this? 
Assignee: verah → dcone
Keywords: crash
Whiteboard: [nsbeta2+]

Comment 6

18 years ago
Thanks Mike!
Assignee: dcone → pinkerton
i put in a small patch in the menu code to try to prevent he b's from being 
selectable so now it can't crash. this bug is really an overlay bug and so isn't 
my domain. saari is looking into this, so i'll push this to him.

removing crash keyword and beta2+ status for recharacterization.
Assignee: pinkerton → saari
Keywords: crash
Whiteboard: [nsbeta2+]

Updated

18 years ago
Whiteboard: [nsbeta2-]

Comment 8

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2. No longer crashes.
(Assignee)

Updated

18 years ago
Target Milestone: --- → Future
(Reporter)

Comment 9

18 years ago
rudman rocks! he noted that clicking to finder and back to netscape results in 
the menu actually drawing the correct menu items.
eli, we knew this all along ;)
(Reporter)

Comment 11

18 years ago
i'm sure you capricious coder-geeks were cognizant that. we black box browser 
boys are occasionally oblivious to such things.

Comment 12

18 years ago
I thought Pinkerton's comment meant that he and others knew that I rock.

I hope he feels that way, heh heh, when I come to talk to him about how tooltips
are implemented ono the Mac (greyed out items should still get tooltips).

ABOUT THIS BUG:
I've seen a 3rd behavior regarding the Help menu---maybe that's known too. In
one session, I saw just Release Notes and About under Help...as if the overlay
wasn't in effect. Known problem? If not, I'll try to reproduce. (I think the
Print Plus item didn't show up in the File menu as well...also related to the
same overlay, according to Ian.)

Comment 13

18 years ago
qa assigning open/resolved help bugs to paw
QA Contact: elig → paw
spam: mass-moving currently open help bugs to Terri, who now does qa on 'em. :)
QA Contact: paw → tpreston
(Assignee)

Comment 15

18 years ago
I don't think we've seen this in a while
Status: NEW → RESOLVED
Last Resolved: 18 years ago
OS: All
Resolution: --- → WORKSFORME

Comment 16

18 years ago
Works for me
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.