*.classname:hover does not fire on Quirks Mode

VERIFIED INVALID

Status

()

--
minor
VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: masa141421356, Unassigned)

Tracking

({css2})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-KS; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080829063055 Minefield/3.1a2pre

CSS selector "*.classname:hover" does not works.
(but "elementname.classname:hover"  works fine)


Reproducible: Always

Steps to Reproduce:
1.see testcase

  <html>
  <head>
  <style type="text/css">
  <!--
  div {color:black; background-color:cyan; height:2em}
  div.a:hover{background-color:yellow}
  *.b:hover{background-color:yellow}
  -->
  </style>
  </head>
  <body>
  <div class="a">div.a:hover</div>
  <div class="b">*.b:hover</div>
  </body>
 </html>

2.move mousecursor on 1st row or 2nd row

Actual Results:  
Only 1st row fires :hover style.


Expected Results:  
both row should fire :hover style.
(Reporter)

Comment 1

10 years ago
Created attachment 336315 [details]
Testcase
(Reporter)

Comment 2

10 years ago
This bug in reproduced ONLY when Quirks mode.
Is it by design ?
Severity: normal → minor
Keywords: css2
Summary: *.classname:hover does not fire. → *.classname:hover does not fire on Quirks Mode
It's an intentional behavior.
http://developer.mozilla.org/en/Mozilla_Quirks_Mode_Behavior
> # The :hover pseudoclass will only be applied to links, images, and form 
> controls, unless the selector includes tag names, ids, or attributes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

10 years ago
Okay. This bug is INVALID.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.